aboutsummaryrefslogtreecommitdiff
path: root/net/svnc
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-22 16:43:20 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-22 16:43:20 +0000
commit7f10612c0d898a85c8c2803bdf7d07773093f6c0 (patch)
tree1d2a01ad5766e8dd735b5809f03982ebc88fc54e /net/svnc
parent1a71f31ac430772b7da4c500f8f5627e0aacca55 (diff)
downloadports-7f10612c0d898a85c8c2803bdf7d07773093f6c0.tar.gz
ports-7f10612c0d898a85c8c2803bdf7d07773093f6c0.zip
Notes
Diffstat (limited to 'net/svnc')
-rw-r--r--net/svnc/Makefile66
-rw-r--r--net/svnc/distinfo2
-rw-r--r--net/svnc/pkg-comment1
-rw-r--r--net/svnc/pkg-descr23
4 files changed, 92 insertions, 0 deletions
diff --git a/net/svnc/Makefile b/net/svnc/Makefile
new file mode 100644
index 000000000000..1ab215188667
--- /dev/null
+++ b/net/svnc/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: svnc
+# Date created: 2000-10-22
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= svnc
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.uk.research.att.com/vnc/contrib/ \
+ http://www.uk.research.att.com/vnc/dist/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz \
+ vnc-3.3.3r1_unixsrc.tgz
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
+
+DOCFILES= README
+DOCDIR= share/doc/${PORTNAME}/
+
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/svncviewer
+
+do-patch:
+ ${PERL} -pi -e "s:include <vncviewer.h>:include \"vncviewer.h\":g" \
+ ${WRKSRC}/*c
+
+do-build:
+ cd ${WRKDIR}/vnc_unixsrc/libvncauth && \
+ ${CC} -I. -I../include -c vncauth.c && \
+ ${CC} -I. -I../include -c d3des.c && \
+ ar clq libvncauth.a *.o && \
+ ranlib libvncauth.a
+ cd ${WRKSRC} && \
+ ${CC} -Wall -L${PREFIX}/lib \
+ -I${X11BASE}/include -I${PREFIX}/include \
+ -I${WRKSRC} -I${WRKSRC}/../vnc_unixsrc/include/ \
+ -I${WRKSRC}/../vnc_unixsrc/vncviewer/ \
+ -lvga -lvgagl \
+ -o svncviewer \
+ args.c rfbproto.c sockets.c svncviewer.c svga.c kbd.c \
+ ${WRKDIR}/vnc_unixsrc/libvncauth/libvncauth.a
+
+pre-install:
+ ${ECHO} "bin/svncviewer" > ${PLIST}
+.if !defined(NOPORTDOCS)
+.for i in ${DOCFILES}
+ ${ECHO} -n ${DOCDIR} >> ${PLIST}
+ ${ECHO} ${i} >> ${PLIST}
+.endfor
+ ${ECHO} -n "@dirrm " >> ${PLIST}
+ ${ECHO} ${DOCDIR} >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL} -c -g wheel -o root -m 4755 ${WRKSRC}/svncviewer ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCDIR}
+.for i in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/svnc/distinfo b/net/svnc/distinfo
new file mode 100644
index 000000000000..ed203c005e89
--- /dev/null
+++ b/net/svnc/distinfo
@@ -0,0 +1,2 @@
+MD5 (svnc-0.1.tgz) = ff918b3e1d77c45e33248c8753723443
+MD5 (vnc-3.3.3r1_unixsrc.tgz) = 55ec5c073ca63068a68f5d3957cd024e
diff --git a/net/svnc/pkg-comment b/net/svnc/pkg-comment
new file mode 100644
index 000000000000..1c786770e563
--- /dev/null
+++ b/net/svnc/pkg-comment
@@ -0,0 +1 @@
+VNC viewer for SVGAlib
diff --git a/net/svnc/pkg-descr b/net/svnc/pkg-descr
new file mode 100644
index 000000000000..530415eb27e3
--- /dev/null
+++ b/net/svnc/pkg-descr
@@ -0,0 +1,23 @@
+This is a VNC viewer for SVGAlib.
+
+from the Web page:
+
+ The viewer doesn't do any scaling or scrolling, so the desktop you
+ connect to must be of a resolution supported by your SVGALIB setup.
+ Try creating servers of different geometries and connecting to them -
+ if your svgalib setup doesn't work for one resolution it may work for
+ another. Persevere - this has a lot of potential. You can use it to
+ make a very lightweight graphics terminal with reasonable performance
+ on low-end hardware.
+
+ The current version will not generally be able to connect to Windows
+ servers, because it requests a palette-based display which the Windows
+ server cannot generate.
+
+If you have problems, press Ctrl+Alt+Backspace, or log in over the network and
+kill the svncviewer process.
+
+WWW: http://www.uk.research.att.com/vnc/platforms.html
+
+Trevor Johnson
+trevor@FreeBSD.org