aboutsummaryrefslogtreecommitdiff
path: root/net/syncthing-cli
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-10-04 15:04:30 +0000
committerSteve Wills <swills@FreeBSD.org>2015-10-04 15:04:30 +0000
commit8b4c709c647e1459638adc81117c608f23bdc746 (patch)
treedcfa95d6d714602306bb3116239464c32bc4238b /net/syncthing-cli
parentb7018751f36bcb6bac95ac50defed338aa883396 (diff)
downloadports-8b4c709c647e1459638adc81117c608f23bdc746.tar.gz
ports-8b4c709c647e1459638adc81117c608f23bdc746.zip
Notes
Diffstat (limited to 'net/syncthing-cli')
-rw-r--r--net/syncthing-cli/Makefile36
-rw-r--r--net/syncthing-cli/distinfo8
-rw-r--r--net/syncthing-cli/files/patch-utils.go11
3 files changed, 7 insertions, 48 deletions
diff --git a/net/syncthing-cli/Makefile b/net/syncthing-cli/Makefile
index 1451b24bbde9..97dfd2513183 100644
--- a/net/syncthing-cli/Makefile
+++ b/net/syncthing-cli/Makefile
@@ -2,50 +2,24 @@
# $FreeBSD$
PORTNAME= syncthing-cli
-PORTVERSION= 0.1.0.2015070301
-PORTREVISION= 2
+PORTVERSION= 0.1.0.2015092201
CATEGORIES= net
MAINTAINER= swills@FreeBSD.org
COMMENT= Syncthing CLI
-BUILD_DEPENDS= go14>=1.4:${PORTSDIR}/lang/go14
+BUILD_DEPENDS= go>=1.5:${PORTSDIR}/lang/go
USE_GITHUB= yes
-GH_ACCOUNT= syncthing AudriusButkevicius:audrius
-GH_PROJECT= syncthing:st cli:audrius
-GH_TAGNAME= 2707f77 v${SYNCTHING_VER}:st 7f561c7:audrius
-
-SYNCTHING_VER= 0.11.18
+GH_ACCOUNT= syncthing
+GH_TAGNAME= 9594d39
PLIST_FILES= bin/syncthing-cli
STRIP= # stripping can break go binaries
-post-patch:
- @${MKDIR} ${WRKSRC}/src/github.com/syncthing
- @${MKDIR} ${WRKSRC}/src/github.com/AudriusButkevicius
- @${MKDIR} ${WRKSRC}/src/code.google.com/p
- @${MKDIR} ${WRKSRC}/src/golang.org/x
- @${MKDIR} ${WRKSRC}/src/github.com/bkaradzic
- @${MV} ${WRKSRC_audrius} \
- ${WRKSRC}/src/github.com/AudriusButkevicius/cli
- @${MV} ${WRKSRC_st}/Godeps/_workspace/src/golang.org/x/crypto \
- ${WRKSRC}/src/golang.org/x
- @${MV} ${WRKSRC_st}/Godeps/_workspace/src/golang.org/x/text \
- ${WRKSRC}/src/golang.org/x
- @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/bkaradzic/go-lz4 \
- ${WRKSRC}/src/github.com/bkaradzic
- @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/calmh \
- ${WRKSRC}/src/github.com/calmh
- @${MV} ${WRKSRC_st} \
- ${WRKSRC}/src/github.com/syncthing/syncthing
- @${MV} ${WRKSRC}/src/github.com/syncthing/syncthing/Godeps/_workspace/src/github.com/syncthing/protocol \
- ${WRKSRC}/src/github.com/syncthing/protocol
-
do-build:
- @cd ${WRKSRC} ; ${SETENV} PATH=${PATH}:${LOCALBASE}/go14/bin \
- GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC}/Godeps/_workspace:${WRKSRC} go build
@${MV} ${WRKSRC}/syncthing-cli-${GH_TAGNAME} ${WRKSRC}/syncthing-cli
do-install:
diff --git a/net/syncthing-cli/distinfo b/net/syncthing-cli/distinfo
index 8877860a72de..03efaa720468 100644
--- a/net/syncthing-cli/distinfo
+++ b/net/syncthing-cli/distinfo
@@ -1,6 +1,2 @@
-SHA256 (syncthing-syncthing-cli-0.1.0.2015070301-2707f77_GH0.tar.gz) = 53c2879f46d0be1f5e8d041968d629ca52b4d28c5e04261b29c960bc84f31e1c
-SIZE (syncthing-syncthing-cli-0.1.0.2015070301-2707f77_GH0.tar.gz) = 9347
-SHA256 (AudriusButkevicius-cli-7f561c7_GH0.tar.gz) = 8d6c282b2737c5ae17c3ba4ce81037762f46aa5a05d0095c0d481639d081110c
-SIZE (AudriusButkevicius-cli-7f561c7_GH0.tar.gz) = 14722
-SHA256 (syncthing-syncthing-v0.11.18_GH0.tar.gz) = fd93392687e545e2b779d10754e24cd49ecbfc03cabaceac381b5a3e69693be6
-SIZE (syncthing-syncthing-v0.11.18_GH0.tar.gz) = 3391683
+SHA256 (syncthing-syncthing-cli-0.1.0.2015092201-9594d39_GH0.tar.gz) = 795d25420ce0a6251c1c0bd520b2801d176b1d4ada562c8fa949e5dd7bcf3532
+SIZE (syncthing-syncthing-cli-0.1.0.2015092201-9594d39_GH0.tar.gz) = 468127
diff --git a/net/syncthing-cli/files/patch-utils.go b/net/syncthing-cli/files/patch-utils.go
deleted file mode 100644
index fda2d14cc71a..000000000000
--- a/net/syncthing-cli/files/patch-utils.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- utils.go
-+++ utils.go
-@@ -146,7 +146,7 @@ func validAddress(input string) {
- if len(tokens) != 2 {
- die(input + " is not a valid value for an address\nExpected format <ip or hostname>:<port>")
- }
-- matched, err := regexp.MatchString("^[a-zA-Z0-9]+([a-zA-Z0-9.]+[a-zA-Z0-9]+)?$", tokens[0])
-+ matched, err := regexp.MatchString("^[a-zA-Z0-9]+([-a-zA-Z0-9.]+[-a-zA-Z0-9]+)?$", tokens[0])
- die(err)
- if !matched {
- die(input + " is not a valid value for an address\nExpected format <ip or hostname>:<port>")