aboutsummaryrefslogtreecommitdiff
path: root/net/syncthing
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-04-04 16:53:37 +0000
committerSteve Wills <swills@FreeBSD.org>2019-04-04 16:53:37 +0000
commit687cbcd189f145d399ee61888fa2a7f3512f4bc8 (patch)
tree0b2353dd472f557a87dd1ba70f842bd1da0b3f0f /net/syncthing
parent3ee06217f1b7fb4f579294691f12ca948dabda25 (diff)
Notes
Diffstat (limited to 'net/syncthing')
-rw-r--r--net/syncthing/Makefile30
-rw-r--r--net/syncthing/distinfo6
-rw-r--r--net/syncthing/files/patch-syncthing_build.go11
3 files changed, 32 insertions, 15 deletions
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index 4a7a5b0bcea5..97ac0e8a2979 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -1,21 +1,23 @@
# $FreeBSD$
PORTNAME= syncthing
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.1
DISTVERSIONPREFIX= v
CATEGORIES= net
+MASTER_SITES= https://github.com/syncthing/syncthing/releases/download/v${PORTVERSION}/
+DISTNAME= ${PORTNAME}-source-${DISTVERSIONPREFIX}${PORTVERSION}
MAINTAINER= swills@FreeBSD.org
COMMENT= Encrypted file sync tool
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/${PORTNAME}/LICENSE
+
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
-USE_GITHUB= yes
-GH_SUBDIR= src/github.com/${PORTNAME}/${PORTNAME}
USE_RC_SUBR= syncthing syncthing-discosrv syncthing-relaysrv syncthing-relaypoolsrv
-BINS= stbench stcli stcompdirs stdisco stdiscosrv stevents stfileinfo \
- stfinddevice stgenfiles stindex strelaypoolsrv strelaysrv \
- stsigtool sttestutil stvanity stwatchfile syncthing
+
+BINS= syncthing stdiscosrv strelaysrv strelaypoolsrv
.for x in ${BINS}
PLIST_FILES+= bin/${x}
@@ -28,20 +30,24 @@ GROUPS= syncthing
OPTIONS_DEFINE= DOCS
+NO_WRKSUBDIR= yes
+
do-build:
- @cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME} ; \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 go run build.go -no-upgrade=true -version v${PORTVERSION}
- @${MV} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/testutil \
- ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/sttestutil
+ @( cd ${WRKSRC}/${PORTNAME} ; \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build ; \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build stdiscosrv ; \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build strelaysrv ; \
+ ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOFLAGS="-mod=vendor" go run build.go -version v${PORTVERSION} -no-upgrade build strelaypoolsrv ; \
+ )
do-install:
.for x in ${BINS}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/${x} \
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${x} \
${STAGEDIR}${PREFIX}/bin/
.endfor
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for x in AUTHORS LICENSE README.md
- ${INSTALL_DATA} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/${x} \
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${x} \
${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/net/syncthing/distinfo b/net/syncthing/distinfo
index 44dc9bf70364..a41f3df1dc10 100644
--- a/net/syncthing/distinfo
+++ b/net/syncthing/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546704293
-SHA256 (syncthing-syncthing-v1.0.0_GH0.tar.gz) = 737161bc87c1f414c142d95e04102de2bbdc8b0bfff908a114898305956a16c1
-SIZE (syncthing-syncthing-v1.0.0_GH0.tar.gz) = 10601948
+TIMESTAMP = 1554384503
+SHA256 (syncthing-source-v1.1.1.tar.gz) = a796583c12894765394be38e8de858705491dc674289bb6936e68aeb4be23477
+SIZE (syncthing-source-v1.1.1.tar.gz) = 6966579
diff --git a/net/syncthing/files/patch-syncthing_build.go b/net/syncthing/files/patch-syncthing_build.go
new file mode 100644
index 000000000000..a97fe7334011
--- /dev/null
+++ b/net/syncthing/files/patch-syncthing_build.go
@@ -0,0 +1,11 @@
+--- syncthing/build.go.orig 2019-04-04 16:46:36 UTC
++++ syncthing/build.go
+@@ -398,7 +398,7 @@ func build(target target, tags []string) {
+
+ rmr(target.BinaryName())
+
+- args := []string{"build", "-v"}
++ args := []string{"build"}
+ args = appendParameters(args, tags, target)
+
+ os.Setenv("GOOS", goos)