aboutsummaryrefslogtreecommitdiff
path: root/net/tcpdstat
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-24 04:58:11 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-24 04:58:11 +0000
commit6d3477014e36dcb852ba93524554dbbb0d3c8e22 (patch)
tree112f3daf3406b2800bf0815f5937709a9af17870 /net/tcpdstat
parent5146cd4f427cef00b1f24596d572b7928910a7c9 (diff)
downloadports-6d3477014e36dcb852ba93524554dbbb0d3c8e22.tar.gz
ports-6d3477014e36dcb852ba93524554dbbb0d3c8e22.zip
Notes
Diffstat (limited to 'net/tcpdstat')
-rw-r--r--net/tcpdstat/Makefile1
-rw-r--r--net/tcpdstat/files/patch-Makefile11
2 files changed, 11 insertions, 1 deletions
diff --git a/net/tcpdstat/Makefile b/net/tcpdstat/Makefile
index 2a9a02bf0dfe..bade1b322a40 100644
--- a/net/tcpdstat/Makefile
+++ b/net/tcpdstat/Makefile
@@ -13,5 +13,4 @@ COMMENT= A tool for generating statistics from tcpdump (libpcap) files
PLIST_FILES= bin/tcpdstat
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/tcpdstat/files/patch-Makefile b/net/tcpdstat/files/patch-Makefile
new file mode 100644
index 000000000000..21f05ffd6702
--- /dev/null
+++ b/net/tcpdstat/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-06-24 12:55:40.174706872 +0800
++++ Makefile 2014-06-24 12:55:48.621709202 +0800
+@@ -11,7 +11,7 @@ INCLUDES= -I. $(SYS_INCLUDES)
+ all: $(PROGS)
+
+ install: $(PROGS)
+- $(INSTALL) $(COPY) -m 0755 $(PROGS) $(PREFIX)/bin
++ $(INSTALL) $(COPY) -m 0755 $(PROGS) $(DESTDIR)$(PREFIX)/bin
+
+ tcpdstat: $(OBJS)
+ $(CC) $(CFLAGS) $(INCLUDES) $(DEFINES) -o $@ $(OBJS) -lpcap -lm $(SYS_LIBS)