aboutsummaryrefslogtreecommitdiff
path: root/net/tcpdump
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-12-11 13:49:52 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-12-11 13:49:52 +0000
commit6256c4e2564045bd90789c107b0940a498c24117 (patch)
treefbf2cff3cc9784894eec595698df510fdfbac77e /net/tcpdump
parente4f09358aecf87e82b47ebe1bfe4711677886166 (diff)
downloadports-6256c4e2564045bd90789c107b0940a498c24117.tar.gz
ports-6256c4e2564045bd90789c107b0940a498c24117.zip
Notes
Diffstat (limited to 'net/tcpdump')
-rw-r--r--net/tcpdump/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 509f8e395a39..db7bc0698ca3 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -22,7 +22,6 @@ MAN1= tcpdump.1
GNU_CONFIGURE= yes
-
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -31,4 +30,20 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --without-crypto
.endif
+LOCALPCAPDIR= ${WRKDIR}/libpcap-0.8.1
+LOCALPCAPFILES= include/pcap.h include/pcap-namedb.h include/pcap-bpf.h \
+ lib/libpcap.a
+
+#
+# When building tcpdump against a particular pcap version, it expects to
+# find a built, untarred source tree in the parent of the work tree.
+# Build a symlink farm to produce the files it wants without requiring
+# pcap to be untarred.
+#
+pre-configure:
+ ${MKDIR} ${LOCALPCAPDIR}
+.for i in ${LOCALPCAPFILES}
+ ${LN} -s ${LOCALBASE}/$i ${LOCALPCAPDIR}
+.endfor
+
.include <bsd.port.mk>