aboutsummaryrefslogtreecommitdiff
path: root/net/tcpflow
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-06-11 18:41:45 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-06-11 18:41:45 +0000
commit5f9e86d15f2c2da6dff884b580612705f61a7cb2 (patch)
tree59f8a1626746628948879d359153b3009e7a651b /net/tcpflow
parent367ca3b349d2115c58acbab5cc2c44c4db49f518 (diff)
downloadports-5f9e86d15f2c2da6dff884b580612705f61a7cb2.tar.gz
ports-5f9e86d15f2c2da6dff884b580612705f61a7cb2.zip
Notes
Diffstat (limited to 'net/tcpflow')
-rw-r--r--net/tcpflow/Makefile37
-rw-r--r--net/tcpflow/distinfo4
-rw-r--r--net/tcpflow/files/patch-datalink.c26
-rw-r--r--net/tcpflow/pkg-descr22
4 files changed, 33 insertions, 56 deletions
diff --git a/net/tcpflow/Makefile b/net/tcpflow/Makefile
index 70f28ab7d7a7..add5afca2210 100644
--- a/net/tcpflow/Makefile
+++ b/net/tcpflow/Makefile
@@ -1,23 +1,36 @@
-# New ports collection makefile for: tcpflow
-# Date created: 20 August 1999
-# Whom: Jose M. Alcaide <jose@we.lc.ehu.es>
-#
+# Created by: Jose M. Alcaide <jose@we.lc.ehu.es>
# $FreeBSD$
-#
PORTNAME= tcpflow
-PORTVERSION= 0.21
-PORTREVISION= 1
+DISTVERSION= 1.4.0b1
CATEGORIES= net
-MASTER_SITES= http://www.circlemud.org/pub/jelson/tcpflow/
+MASTER_SITES= http://www.digitalcorpora.org/downloads/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A tool for capturing data transmitted as part of TCP connections
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Program that captures data transmitted as part of TCP connections
-HAS_CONFIGURE= yes
-USE_AUTOTOOLS= automake14
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/icl/interval.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
+
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= tcpflow.1
PLIST_FILES= bin/tcpflow
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/net/tcpflow/distinfo b/net/tcpflow/distinfo
index 791cd2135caf..cbb2e4fd84bc 100644
--- a/net/tcpflow/distinfo
+++ b/net/tcpflow/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tcpflow-0.21.tar.gz) = 16928bd9721c0de685b66365d320bcd52a97a4edf0e1087654ad8db379d19469
-SIZE (tcpflow-0.21.tar.gz) = 79369
+SHA256 (tcpflow-1.4.0b1.tar.gz) = 4d7a9e2dc7cd8637837a6af61a05825a1285333a23264333bccf5d01c8aed29d
+SIZE (tcpflow-1.4.0b1.tar.gz) = 428714
diff --git a/net/tcpflow/files/patch-datalink.c b/net/tcpflow/files/patch-datalink.c
deleted file mode 100644
index 32df9f1d5efd..000000000000
--- a/net/tcpflow/files/patch-datalink.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/datalink.c.orig Mon May 9 12:00:38 2005
-+++ src/datalink.c Mon May 9 12:23:47 2005
-@@ -42,6 +42,13 @@
-
- #include "tcpflow.h"
-
-+/*
-+ * Byte-swap a 32-bit number.
-+ * ("htonl()" or "ntohl()" won't work - we want to byte-swap even on
-+ * big-endian platforms.)
-+ */
-+#define SWAPLONG(y) \
-+((((y)&0xff)<<24) | (((y)&0xff00)<<8) | (((y)&0xff0000)>>8) | (((y)>>24)&0xff))
-
-
- /* The DLT_NULL packet header is 4 bytes long. It contains a network
-@@ -71,7 +78,8 @@
- #ifndef DLT_NULL_BROKEN
- /* make sure this is AF_INET */
- memcpy((char *)&family, (char *)p, sizeof(family));
-- family = ntohl(family);
-+ // family = ntohl(family);
-+ if ((family & 0xFFFF0000) != 0) family = SWAPLONG(family);
- if (family != AF_INET) {
- DEBUG(6) ("warning: received non-AF_INET null frame (type %d)", family);
- return;
diff --git a/net/tcpflow/pkg-descr b/net/tcpflow/pkg-descr
index 00139967959d..1eda63646897 100644
--- a/net/tcpflow/pkg-descr
+++ b/net/tcpflow/pkg-descr
@@ -1,18 +1,8 @@
tcpflow is a program that captures data transmitted as part of TCP
-connections (flows), and stores it in a way that is convenient for
-protocol analysis or debugging. A program like 'tcpdump' only shows a
-summary of packets seen on the wire, but usually doesn't store the
-data that's actually being transmitted. In contrast, tcpflow
-reconstructs the actual data streams and stores each flow in a
-separate file for later analysis.
+connections (flows), and stores the data in a way that is convenient
+for protocol analysis and debugging. Each TCP flow is stored in its
+own file. Thus, the typical TCP flow will be stored in two files, one
+for each direction. tcpflow can also process stored 'tcpdump' packet
+flows.
-tcpflow understands sequence numbers and will correctly reconstruct
-data streams regardless of retransmissions or out-of-order delivery.
-However, it currently does not understand IP fragments; flows
-containing IP fragments will not be recorded properly.
-
-Note: this port includes a small patch that adds the capability of
- reading the packets from a tcpdump(1) capture file, using
- a new option (-r).
-
-WWW: http://www.circlemud.org/~jelson/software/tcpflow/
+WWW: https://github.com/simsong/tcpflow