aboutsummaryrefslogtreecommitdiff
path: root/net/tcpmssd/Makefile
diff options
context:
space:
mode:
authorRuslan Ermilov <ru@FreeBSD.org>2004-06-11 18:52:39 +0000
committerRuslan Ermilov <ru@FreeBSD.org>2004-06-11 18:52:39 +0000
commit3db850ffd55d76659dd0472d6e840f5bcc4a6b03 (patch)
tree2d301d9a3858cfd59cdc9cf0eae86c92e940444e /net/tcpmssd/Makefile
parenta427774043cebe390ce8d6fd0b84f14037706265 (diff)
downloadports-3db850ffd55d76659dd0472d6e840f5bcc4a6b03.tar.gz
ports-3db850ffd55d76659dd0472d6e840f5bcc4a6b03.zip
Notes
Diffstat (limited to 'net/tcpmssd/Makefile')
-rw-r--r--net/tcpmssd/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/net/tcpmssd/Makefile b/net/tcpmssd/Makefile
index 77f6eca6880b..b3bc750c7dbe 100644
--- a/net/tcpmssd/Makefile
+++ b/net/tcpmssd/Makefile
@@ -8,14 +8,30 @@
PORTNAME= tcpmssd
PORTVERSION= 1.0
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR=ru
+MASTER_SITES= # none
+DISTFILES= # none
MAINTAINER= ru@FreeBSD.org
-COMMENT= A divert(4) daemon to correct requested receive segment size for TCP traffic
+COMMENT= A utility to correct requested TCP receive segment size
+
+WRKSRC= ${WRKDIR}/src
+
+SRC= ${.CURDIR}/src
MAN8= tcpmssd.8
-MANCOMPRESSED= maybe
PLIST_FILES= bin/tcpmssd
+do-fetch:
+ @${DO_NADA}
+
+pre-patch:
+ @${CP} -R ${SRC} ${WRKDIR}
+
+do-build:
+ (cd ${WRKSRC} && ${MAKE} tcpmssd)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpmssd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tcpmssd.8 ${MAN8PREFIX}/man/man8
+
.include <bsd.port.mk>