aboutsummaryrefslogtreecommitdiff
path: root/net/tcpsplit
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-05-03 20:39:58 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-05-03 20:39:58 +0000
commit6d6c406b581fbe3b3959cf3e9943aae1263592ff (patch)
tree7560957d638727c2370fdde080c3c20bb174d25a /net/tcpsplit
parenta13e169046abbb3a7eba7af689ef434df4a74e81 (diff)
downloadports-6d6c406b581fbe3b3959cf3e9943aae1263592ff.tar.gz
ports-6d6c406b581fbe3b3959cf3e9943aae1263592ff.zip
Notes
Diffstat (limited to 'net/tcpsplit')
-rw-r--r--net/tcpsplit/Makefile29
-rw-r--r--net/tcpsplit/distinfo2
-rw-r--r--net/tcpsplit/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/net/tcpsplit/Makefile b/net/tcpsplit/Makefile
new file mode 100644
index 000000000000..f6df060f3a35
--- /dev/null
+++ b/net/tcpsplit/Makefile
@@ -0,0 +1,29 @@
+# Created by: Lars Eggert <lars@eggert.org>
+# $FreeBSD$
+
+PORTNAME= tcpsplit
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://www.icir.org/mallman/software/tcpsplit/
+
+MAINTAINER= lars@eggert.org
+COMMENT= Breaks a libpcap trace along TCP connection boundaries
+
+LICENSE= MIT
+
+PLIST_FILES= bin/tcpsplit
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^(CC|CFLAGS|INC|LD)/d' ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpsplit ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tcpsplit/distinfo b/net/tcpsplit/distinfo
new file mode 100644
index 000000000000..e8d9d961e919
--- /dev/null
+++ b/net/tcpsplit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tcpsplit-0.2.tar.gz) = 885a6609d04eb35f31f1c6f06a0b9afd88776d85dec0caa33a86cef3f3c09d1d
+SIZE (tcpsplit-0.2.tar.gz) = 6685
diff --git a/net/tcpsplit/pkg-descr b/net/tcpsplit/pkg-descr
new file mode 100644
index 000000000000..017bcdf1c18a
--- /dev/null
+++ b/net/tcpsplit/pkg-descr
@@ -0,0 +1,7 @@
+The tcpsplit utility breaks a single libpcap packet trace into some number
+of sub-traces, breaking the trace along TCP connection boundaries so that
+a TCP connection doesn't end up split across two sub-traces. This is useful
+for making large trace files tractable for in-depth analysis and for
+subsetting a trace for developing analysis on only part of a trace.
+
+WWW: http://www.icir.org/mallman/software/tcpsplit/