aboutsummaryrefslogtreecommitdiff
path: root/net/tcptrace
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 18:02:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 18:02:26 +0000
commitfa80014180872977a3e11add4ae53dcf60f6ba1f (patch)
tree959841612e0b2c604a1d83c467e2e282a6ce79a1 /net/tcptrace
parent4da8c354c54d1439e8b9279cdcca93c955db3d95 (diff)
downloadports-fa80014180872977a3e11add4ae53dcf60f6ba1f.tar.gz
ports-fa80014180872977a3e11add4ae53dcf60f6ba1f.zip
Notes
Diffstat (limited to 'net/tcptrace')
-rw-r--r--net/tcptrace/Makefile10
-rw-r--r--net/tcptrace/distinfo4
-rw-r--r--net/tcptrace/files/patch-ad65
-rw-r--r--net/tcptrace/files/patch-tcpdump.c.diff17
-rw-r--r--net/tcptrace/files/patch-tcpdump.h.diff34
-rw-r--r--net/tcptrace/files/patch-tcptrace.h.diff13
-rw-r--r--net/tcptrace/pkg-plist32
7 files changed, 88 insertions, 87 deletions
diff --git a/net/tcptrace/Makefile b/net/tcptrace/Makefile
index cfa1810ae53e..a9f8462d44eb 100644
--- a/net/tcptrace/Makefile
+++ b/net/tcptrace/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tcptrace
-PORTVERSION= 6.6.0
+PORTVERSION= 6.6.7
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcptrace.org/download/
@@ -26,11 +26,13 @@ DOCFILES= ARGS CHANGES COPYING COPYRIGHT FAQ README README.mailing_list \
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcptrace ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/xpl2gpl ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/tcptrace.man ${PREFIX}/man/man1/tcptrace.1
- ${MKDIR} ${PREFIX}/share/doc/tcptrace
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
.for file in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/tcptrace
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/net/tcptrace/distinfo b/net/tcptrace/distinfo
index 9dc9e169c567..da3783c52fec 100644
--- a/net/tcptrace/distinfo
+++ b/net/tcptrace/distinfo
@@ -1,2 +1,2 @@
-MD5 (tcptrace-6.6.0.tar.gz) = 9d71ee3c75e142cd46cf0d412b7d6e89
-SIZE (tcptrace-6.6.0.tar.gz) = 3762654
+MD5 (tcptrace-6.6.7.tar.gz) = 68128dc1817b866475e2f048e158f5b9
+SIZE (tcptrace-6.6.7.tar.gz) = 3773308
diff --git a/net/tcptrace/files/patch-ad b/net/tcptrace/files/patch-ad
deleted file mode 100644
index 0ed76c9ceda9..000000000000
--- a/net/tcptrace/files/patch-ad
+++ /dev/null
@@ -1,65 +0,0 @@
-Index: tcpdump.c
-===========================================================================
---- tcpdump.c 2004/11/17 22:48:46 #1
-+++ tcpdump.c 2004/11/17 22:48:46
-@@ -112,6 +112,9 @@
- {
- case -1: /* Not an IP packet */
- return (-1);
-+ case EH_SIZE + ETHER_VLAN_ENCAP_LEN:
-+ memcpy(&eth_header.ether_type, buf+EH_SIZE+2, 2);
-+ /* FALLTHROUGH */
- case EH_SIZE: /* straight Ethernet encapsulation */
- memcpy((char *)ip_buf,buf+offset,iplen);
- callback_plast = ip_buf+iplen-offset-1;
-Index: tcpdump.h
-===========================================================================
---- tcpdump.h 2004/11/17 22:48:46 #1
-+++ tcpdump.h 2004/11/17 22:48:46
-@@ -178,7 +178,7 @@
- }
-
- /* This function determine the offset for the IP packet in an Ethernet frame */
--/* We handle two cases : straight Ethernet encapsulation or PPPoE encapsulation */
-+/* We handle three cases : straight Ethernet, PPPoE, or .1q VLAN encapsulation */
- /* Written by Yann Samama (ysamama@nortelnetworks.com) on july 18th, 2003 */
- static int find_ip_eth(char* buf)
- {
-@@ -191,10 +191,8 @@
- switch (eth_proto_type)
- {
- case ETHERTYPE_IPV6: /* it's pure IPv6 over ethernet */
-- offset = 14;
-- break;
- case ETHERTYPE_IP: /* it's pure IPv4 over ethernet */
-- offset = 14;
-+ offset = sizeof(struct ether_header);
- break;
- case ETHERTYPE_PPPOE_SESSION: /* it's a PPPoE session */
- memcpy(&ppp_proto_type, buf+20, 2);
-@@ -202,6 +200,10 @@
- if (ppp_proto_type == 0x0021) /* it's IP over PPPoE */
- offset = PPPOE_SIZE;
- break;
-+ case ETHERTYPE_VLAN:
-+ offset = sizeof(struct ether_header) +
-+ ETHER_VLAN_ENCAP_LEN;
-+ break;
- default: /* well, this is not an IP packet */
- offset = -1;
- break;
-Index: tcptrace.h
-===========================================================================
---- tcptrace.h 2004/11/17 22:48:46 #1
-+++ tcptrace.h 2004/11/17 22:48:46
-@@ -1172,6 +1172,10 @@
- #define ETHERTYPE_VLAN 0x8100
- #endif /* 802.1Q Virtual LAN */
-
-+#ifndef ETHER_VLAN_ENCAP_LEN
-+#define ETHER_VLAN_ENCAP_LEN 4
-+#endif /* 802.1Q tag header length */
-+
- /* support for PPPoE encapsulation added by Yann Samama (ysamama@nortelnetworks.com)*/
- #ifndef ETHERTYPE_PPPOE_SESSION
- #define ETHERTYPE_PPPOE_SESSION 0x8864
diff --git a/net/tcptrace/files/patch-tcpdump.c.diff b/net/tcptrace/files/patch-tcpdump.c.diff
new file mode 100644
index 000000000000..6741840aaa4f
--- /dev/null
+++ b/net/tcptrace/files/patch-tcpdump.c.diff
@@ -0,0 +1,17 @@
+--- tcpdump.c.orig Thu May 5 18:41:30 2005
++++ tcpdump.c Thu May 5 18:41:53 2005
+@@ -112,10 +112,13 @@
+ /* for some reason, the windows version of tcpdump is using */
+ /* this. It looks just like ethernet to me */
+ case PCAP_DLT_EN10MB:
+- offset = find_ip_eth(buf); /* Here we check if we are dealing with Straight Ethernet encapsulation or PPPoE */
++ offset = find_ip_eth(buf); /* Here we check if we are dealing with Straight Ethernet encapsulation, PPPoE or .1q VLAN encapsulation */
+ memcpy(&eth_header, buf, EH_SIZE); /* save ether header */
+ switch (offset)
+ {
++ case EH_SIZE + ETHER_VLAN_ENCAP_LEN:
++ memcpy(&eth_header.ether_type, buf+EH_SIZE+2, 2);
++ /* FALLTHROUGH */
+ case EH_SIZE: /* straight Ethernet encapsulation */
+ memcpy((char *)ip_buf,buf+offset,iplen-offset);
+ callback_plast = ip_buf+iplen-offset-1;
diff --git a/net/tcptrace/files/patch-tcpdump.h.diff b/net/tcptrace/files/patch-tcpdump.h.diff
new file mode 100644
index 000000000000..f64859705096
--- /dev/null
+++ b/net/tcptrace/files/patch-tcpdump.h.diff
@@ -0,0 +1,34 @@
+--- tcpdump.h.orig Thu May 5 18:41:37 2005
++++ tcpdump.h Thu May 5 18:41:53 2005
+@@ -179,7 +179,7 @@
+ }
+
+ /* This function determine the offset for the IP packet in an Ethernet frame */
+-/* We handle two cases : straight Ethernet encapsulation or PPPoE encapsulation */
++/* We handle three cases : straight Ethernet, PPPoE, or .1q VLAN encapsulation */
+ /* Written by Yann Samama (ysamama@nortelnetworks.com) on july 18th, 2003 */
+ static int find_ip_eth(char* buf)
+ {
+@@ -192,16 +192,19 @@
+ switch (eth_proto_type)
+ {
+ case ETHERTYPE_IPV6: /* it's pure IPv6 over ethernet */
+- offset = 14;
+- break;
++ /* FALLTHROUGH */
+ case ETHERTYPE_IP: /* it's pure IPv4 over ethernet */
+- offset = 14;
++ offset = sizeof(struct ether_header);
+ break;
+ case ETHERTYPE_PPPOE_SESSION: /* it's a PPPoE session */
+ memcpy(&ppp_proto_type, buf+20, 2);
+ ppp_proto_type = ntohs(ppp_proto_type);
+ if (ppp_proto_type == 0x0021) /* it's IP over PPPoE */
+ offset = PPPOE_SIZE;
++ break;
++ case ETHERTYPE_VLAN:
++ offset = sizeof(struct ether_header) +
++ ETHER_VLAN_ENCAP_LEN;
+ break;
+ default: /* well, this is not an IP packet */
+ offset = -1;
diff --git a/net/tcptrace/files/patch-tcptrace.h.diff b/net/tcptrace/files/patch-tcptrace.h.diff
new file mode 100644
index 000000000000..8c3a44487abb
--- /dev/null
+++ b/net/tcptrace/files/patch-tcptrace.h.diff
@@ -0,0 +1,13 @@
+--- tcptrace.h.orig Thu May 5 18:41:47 2005
++++ tcptrace.h Thu May 5 18:41:53 2005
+@@ -1182,6 +1182,10 @@
+ #define ETHERTYPE_VLAN 0x8100
+ #endif /* 802.1Q Virtual LAN */
+
++#ifndef ETHER_VLAN_ENCAP_LEN
++#define ETHER_VLAN_ENCAP_LEN 4
++#endif /* 802.1Q tag header length */
++
+ /* support for PPPoE encapsulation added by Yann Samama (ysamama@nortelnetworks.com)*/
+ #ifndef ETHERTYPE_PPPOE_SESSION
+ #define ETHERTYPE_PPPOE_SESSION 0x8864
diff --git a/net/tcptrace/pkg-plist b/net/tcptrace/pkg-plist
index d6a0ae40b60e..45070dd99a4e 100644
--- a/net/tcptrace/pkg-plist
+++ b/net/tcptrace/pkg-plist
@@ -1,18 +1,18 @@
bin/tcptrace
bin/xpl2gpl
-share/doc/tcptrace/ARGS
-share/doc/tcptrace/CHANGES
-share/doc/tcptrace/COPYING
-share/doc/tcptrace/COPYRIGHT
-share/doc/tcptrace/FAQ
-share/doc/tcptrace/README
-share/doc/tcptrace/README.mailing_list
-share/doc/tcptrace/README.modules
-share/doc/tcptrace/README.tline_graphs
-share/doc/tcptrace/README.tput_graphs
-share/doc/tcptrace/README.version
-share/doc/tcptrace/README.xpl2gpl
-share/doc/tcptrace/THANKS
-share/doc/tcptrace/WWW
-share/doc/tcptrace/dot_tcptracerc
-@dirrm share/doc/tcptrace
+%%PORTDOCS%%%%DOCSDIR%%/ARGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.mailing_list
+%%PORTDOCS%%%%DOCSDIR%%/README.modules
+%%PORTDOCS%%%%DOCSDIR%%/README.tline_graphs
+%%PORTDOCS%%%%DOCSDIR%%/README.tput_graphs
+%%PORTDOCS%%%%DOCSDIR%%/README.version
+%%PORTDOCS%%%%DOCSDIR%%/README.xpl2gpl
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/WWW
+%%PORTDOCS%%%%DOCSDIR%%/dot_tcptracerc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%