aboutsummaryrefslogtreecommitdiff
path: root/net/tcptraceroute-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:08:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:08:27 +0000
commitf3a0dc913613f2fa4022d4c99e413ea63cf0d60f (patch)
treec5ef9763ab6954f10ddfeb964116f369fa2bb164 /net/tcptraceroute-devel
parent87f4d287177e54c709f3dc05027ac2b74266d97b (diff)
downloadports-f3a0dc913613f2fa4022d4c99e413ea63cf0d60f.tar.gz
ports-f3a0dc913613f2fa4022d4c99e413ea63cf0d60f.zip
Notes
Diffstat (limited to 'net/tcptraceroute-devel')
-rw-r--r--net/tcptraceroute-devel/Makefile43
-rw-r--r--net/tcptraceroute-devel/distinfo6
-rw-r--r--net/tcptraceroute-devel/files/patch-Makefile36
-rw-r--r--net/tcptraceroute-devel/files/patch-configure46
-rw-r--r--net/tcptraceroute-devel/files/patch-tcptraceroute.c26
-rw-r--r--net/tcptraceroute-devel/pkg-descr2
-rw-r--r--net/tcptraceroute-devel/pkg-plist10
7 files changed, 88 insertions, 81 deletions
diff --git a/net/tcptraceroute-devel/Makefile b/net/tcptraceroute-devel/Makefile
index 85a40f770c37..020b3b9098de 100644
--- a/net/tcptraceroute-devel/Makefile
+++ b/net/tcptraceroute-devel/Makefile
@@ -1,31 +1,48 @@
-# New ports collection makefile for: tcptraceroute
-# Date created: 21 March 2002
-# Whom: jeff@cetlink.net
+# New ports collection makefile for: tcptraceroute-devel
+# Date created: 12 December 2007
+# Whom: josh.carroll@gmail.com
#
# $FreeBSD$
#
PORTNAME= tcptraceroute
-PORTVERSION= 1.4
-PORTREVISION= 2
+DISTVERSION= 1.5beta7
CATEGORIES= net
MASTER_SITES= http://michael.toren.net/code/tcptraceroute/ \
- http://sunpoet.net/distfiles/
+ http://pflog.net/tcptraceroute/
+PKGNAMESUFFIX= -devel
-MAINTAINER= sunpoet@sunpoet.net
+MAINTAINER= josh.carroll@gmail.com
COMMENT= A traceroute implementation using TCP packets
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
-MAN8= tcptraceroute.8
+CONFLICTS= tcptraceroute-1.4*
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
+MAN1= tcptraceroute.1
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+CONFIGURE_ARGS= --with-libpcap=/usr --bindir=${PREFIX}/sbin
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+INSTALL_TARGET= install-exec-am install-man
post-install:
@${CHMOD} u+s ${PREFIX}/sbin/tcptraceroute
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/tcptraceroute.1.html ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/tcptraceroute.lsm ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/NEWS ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/examples.txt ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net/tcptraceroute-devel/distinfo b/net/tcptraceroute-devel/distinfo
index e0db77591118..41ed332fd74e 100644
--- a/net/tcptraceroute-devel/distinfo
+++ b/net/tcptraceroute-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (tcptraceroute-1.4.tar.gz) = 35c5e7d960f2b073db0109e0004e134e
-SHA256 (tcptraceroute-1.4.tar.gz) = 1ef6c4736b55f47d3a2bb26b999cbb409953a112f637bcbec4106da2a0937bde
-SIZE (tcptraceroute-1.4.tar.gz) = 31918
+MD5 (tcptraceroute-1.5beta7.tar.gz) = 65d1001509f971ea986fcbc2dd009643
+SHA256 (tcptraceroute-1.5beta7.tar.gz) = aed5b163ed4886f04242b46005a6cb4876ef38ad72001a94facb62a99dc99c57
+SIZE (tcptraceroute-1.5beta7.tar.gz) = 119119
diff --git a/net/tcptraceroute-devel/files/patch-Makefile b/net/tcptraceroute-devel/files/patch-Makefile
deleted file mode 100644
index f137ff657f9d..000000000000
--- a/net/tcptraceroute-devel/files/patch-Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
---- Makefile.orig Mon May 20 03:11:38 2002
-+++ Makefile Tue Aug 20 01:49:27 2002
-@@ -3,20 +3,27 @@
- # tcptraceroute -- A traceroute implementation using TCP packets
- # Copyright (c) 2001, 2002 Michael C. Toren <mct@toren.net>
-
--CC = gcc
--CFLAGS = -O2 -Wall
--DESTDIR=/usr/local/bin
-+CC?= cc
-+CFLAGS?= -O -pipe -Wall
-+LNETINC= `libnet-config --cflags`
-+LNETLIB= `libnet-config --libs`
-+
-+BINDIR= ${PREFIX}/sbin
-+MANDIR= ${PREFIX}/man
-+
-+all: tcptraceroute
-
- tcptraceroute: tcptraceroute.c
-- $(CC) $(CFLAGS) `libnet-config --defines` \
-+ $(CC) $(CFLAGS) `libnet-config --defines` $(LNETINC) \
- -o tcptraceroute tcptraceroute.c \
-- `libnet-config --libs` -lpcap
-+ $(LNETLIB) -lpcap
-
- static:
- $(MAKE) tcptraceroute CFLAGS="$(CFLAGS) -static"
-
- install: tcptraceroute
-- install -D tcptraceroute $(DESTDIR)/tcptraceroute
-+ install -c -s tcptraceroute $(BINDIR)/tcptraceroute
-+ install -c -m 444 tcptraceroute.8 $(MANDIR)/man8/tcptraceroute.8
-
- distrib: clean changelog man
-
diff --git a/net/tcptraceroute-devel/files/patch-configure b/net/tcptraceroute-devel/files/patch-configure
new file mode 100644
index 000000000000..9fe536ac4aa0
--- /dev/null
+++ b/net/tcptraceroute-devel/files/patch-configure
@@ -0,0 +1,46 @@
+--- configure.old 2006-03-28 20:49:55.000000000 -0500
++++ configure 2007-12-13 13:57:42.000000000 -0500
+@@ -3713,38 +3713,11 @@
+
+ fi;
+
+-LIBNET_CONFIG="libnet-config" # relative, using $PATH
+-
+-# Check whether --with-libnet or --without-libnet was given.
+-if test "${with_libnet+set}" = set; then
+- withval="$with_libnet"
+-
+- LIBNETCC=""
+- LIBNETLD=""
+-
+- test -x "$withval/bin/libnet-config" && LIBNET_CONFIG="$withval/bin/libnet-config"
+- test -x "$withval/libnet-config" && LIBNET_CONFIG="$withval/libnet-config"
+-
+- test -f "$withval/libnet.h" && LIBNETCC="$LIBNETCC -I$withval"
+- test -f "$withval/include/libnet.h" && LIBNETCC="$LIBNETCC -I$withval/include"
+-
+- test -f "$withval/libnet.a" && LIBNETLD="$LIBNETLD -L$withval"
+- test -f "$withval/lib/libnet.a" && LIBNETLD="$LIBNETLD -L$withval/lib"
+-
+- if test -z "$LIBNETCC" -o -z "$LIBNETLD"
+- then
+- { { echo "$as_me:$LINENO: error: No valid libnet library found in $withval" >&5
+-echo "$as_me: error: No valid libnet library found in $withval" >&2;}
+- { (exit 1); exit 1; }; }
+- else
+- CPPFLAGS="$CPPFLAGS $LIBNETCC"
+- LDFLAGS="$LDFLAGS $LIBNETLD"
+- { echo "$as_me:$LINENO: using libnet in $withval" >&5
+-echo "$as_me: using libnet in $withval" >&6;}
+- fi
+-
+-fi;
+-
++LIBNET_CONFIG="libnet11-config" # relative, using $PATH
++LIBNETCC=`$LIBNET_CONFIG --cflags`
++LIBNETLD=`$LIBNET_CONFIG --libs`
++CPPFLAGS="$CPPFLAGS $LIBNETCC"
++LDFLAGS="$LDFLAGS $LIBNETLD"
+
+ echo "$as_me:$LINENO: checking for pcap_open_live in -lpcap" >&5
+ echo $ECHO_N "checking for pcap_open_live in -lpcap... $ECHO_C" >&6
diff --git a/net/tcptraceroute-devel/files/patch-tcptraceroute.c b/net/tcptraceroute-devel/files/patch-tcptraceroute.c
deleted file mode 100644
index 28f15e1b7051..000000000000
--- a/net/tcptraceroute-devel/files/patch-tcptraceroute.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- tcptraceroute.c.orig Tue Oct 7 16:04:50 2003
-+++ tcptraceroute.c Tue Oct 7 16:05:22 2003
-@@ -391,9 +391,9 @@
- void usage(void)
- {
- printf("\n%s\n%s\n", VERSION, BANNER);
-- fatal("Usage: %s [-nNFSAE] [-i <interface>] [-f <first ttl>]
-- [-l <packet length>] [-q <number of queries>] [-t <tos>]
-- [-m <max ttl>] [-pP] <source port>] [-s <source address>]
-+ fatal("Usage: %s [-nNFSAE] [-i <interface>] [-f <first ttl>] \
-+ [-l <packet length>] [-q <number of queries>] [-t <tos>] \
-+ [-m <max ttl>] [-pP] <source port>] [-s <source address>] \
- [-w <wait time>] <host> [destination port] [packet length]\n\n", name);
- }
-
-@@ -1182,8 +1182,8 @@
- if (! (pcap = pcap_open_live(device, offset + SNAPLEN, 0, 10, errbuf)))
- fatal("pcap_open_live failed: %s", errbuf);
-
-- safe_snprintf(filter, TEXTSIZE, "
-- (tcp and src host %s and src port %d and dst host %s)
-+ safe_snprintf(filter, TEXTSIZE, " \
-+ (tcp and src host %s and src port %d and dst host %s) \
- or ((icmp[0] == 11 or icmp[0] == 3) and dst host %s)",
- iptos(dst_ip), dst_prt, iptos(src_ip), iptos(src_ip));
-
diff --git a/net/tcptraceroute-devel/pkg-descr b/net/tcptraceroute-devel/pkg-descr
index b64b1179851b..35920dc8ed50 100644
--- a/net/tcptraceroute-devel/pkg-descr
+++ b/net/tcptraceroute-devel/pkg-descr
@@ -16,5 +16,3 @@ UDP or ICMP ECHO packets, tcptraceroute is able to bypass the most
common firewall filters.
WWW: http://michael.toren.net/code/tcptraceroute/
-
-- Simon 'corecode' Schubert
diff --git a/net/tcptraceroute-devel/pkg-plist b/net/tcptraceroute-devel/pkg-plist
index cbdc4f42fa33..7e278be821d7 100644
--- a/net/tcptraceroute-devel/pkg-plist
+++ b/net/tcptraceroute-devel/pkg-plist
@@ -1,2 +1,10 @@
-@comment $FreeBSD$
sbin/tcptraceroute
+%%PORTDOCS%%%%DOCSDIR%%/tcptraceroute.1.html
+%%PORTDOCS%%%%DOCSDIR%%/tcptraceroute.lsm
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/examples.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%