aboutsummaryrefslogtreecommitdiff
path: root/net/tcpwatch
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-16 20:50:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-16 20:50:59 +0000
commita736a2d96f6dec108e0ea4cdbf5d17faacb6bbba (patch)
tree3d187b9939f06e7651ecacf8dab5afa722d29c42 /net/tcpwatch
parentf89b030b445c3404176e56c180d827b2f4ca49a6 (diff)
downloadports-a736a2d96f6dec108e0ea4cdbf5d17faacb6bbba.tar.gz
ports-a736a2d96f6dec108e0ea4cdbf5d17faacb6bbba.zip
Notes
Diffstat (limited to 'net/tcpwatch')
-rw-r--r--net/tcpwatch/Makefile24
-rw-r--r--net/tcpwatch/distinfo2
-rw-r--r--net/tcpwatch/pkg-descr7
3 files changed, 33 insertions, 0 deletions
diff --git a/net/tcpwatch/Makefile b/net/tcpwatch/Makefile
new file mode 100644
index 000000000000..fbb3b891ab1c
--- /dev/null
+++ b/net/tcpwatch/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: tcpwatch
+# Date created: 2004-05-11
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpwatch
+PORTVERSION= 1.2.1
+CATEGORIES= net python
+MASTER_SITES= http://hathaway.freezope.org/Software/TCPWatch/
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= TCP monitoring and logging tool with support for HTTP 1.1
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/tcpwatch.py
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/net/tcpwatch/distinfo b/net/tcpwatch/distinfo
new file mode 100644
index 000000000000..2d923137b845
--- /dev/null
+++ b/net/tcpwatch/distinfo
@@ -0,0 +1,2 @@
+MD5 (tcpwatch-1.2.1.tar.gz) = 3575838ef4ece653251f92a38670e8cc
+SIZE (tcpwatch-1.2.1.tar.gz) = 12525
diff --git a/net/tcpwatch/pkg-descr b/net/tcpwatch/pkg-descr
new file mode 100644
index 000000000000..7aa44987ae2b
--- /dev/null
+++ b/net/tcpwatch/pkg-descr
@@ -0,0 +1,7 @@
+TCPWatch is a utility written in Python that lets you monitor forwarded TCP
+connections or HTTP proxy connections. It displays the sessions in a window
+with a history of past connections. It is useful for developing and debugging
+protocol implementations and web services.
+
+Author: Shane Hathaway <shane@zope.com>
+WWW: http://hathaway.freezope.org/Software/TCPWatch