aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++-devel
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-26 14:53:16 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-26 14:53:16 +0000
commitbe2cada2b99773f35f754ea66de6253c59b51324 (patch)
treea05104ecc63891135b2628ebdaa39ef198c5a0d8 /net/tintin++-devel
parent85abfe1718c130f603297b7b8c751d94b47fac83 (diff)
downloadports-be2cada2b99773f35f754ea66de6253c59b51324.tar.gz
ports-be2cada2b99773f35f754ea66de6253c59b51324.zip
Notes
Diffstat (limited to 'net/tintin++-devel')
-rw-r--r--net/tintin++-devel/Makefile6
-rw-r--r--net/tintin++-devel/distinfo2
-rw-r--r--net/tintin++-devel/files/patch-ab19
-rw-r--r--net/tintin++-devel/files/patch-ac22
-rw-r--r--net/tintin++-devel/files/patch-ad11
-rw-r--r--net/tintin++-devel/files/patch-ae11
6 files changed, 48 insertions, 23 deletions
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index 7b75c2809bbf..ff5db97304ee 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= tintin
-PORTVERSION= 1.8.2
+PORTVERSION= 1.8.3
CATEGORIES= net games
MASTER_SITES= http://mail.newclear.net/tintin/download/
-DISTNAME= tintin++v1.82
+DISTNAME= tintin++v1.83
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhp@cocoja.holywar.net
WRKSRC= ${WRKDIR}/tintin++/src
GNU_CONFIGURE= yes
diff --git a/net/tintin++-devel/distinfo b/net/tintin++-devel/distinfo
index f300c5cf4edf..f4e33f921a8f 100644
--- a/net/tintin++-devel/distinfo
+++ b/net/tintin++-devel/distinfo
@@ -1 +1 @@
-MD5 (tintin++v1.82.tar.gz) = 8817be7ba82283f507953f17ef4d7743
+MD5 (tintin++v1.83.tar.gz) = 468f690e82bf0a511771a861dc2918cd
diff --git a/net/tintin++-devel/files/patch-ab b/net/tintin++-devel/files/patch-ab
index 2c4d5833b31f..1476695c8de6 100644
--- a/net/tintin++-devel/files/patch-ab
+++ b/net/tintin++-devel/files/patch-ab
@@ -17,22 +17,3 @@
char homepath[1025];
char prompt_line[BUFFER_SIZE];
-*** chat.c.orig Sat Sep 2 10:34:02 2000
---- chat.c Sat Sep 2 10:33:32 2000
-***************
-*** 1458,1464 ****
- if ((f = fopen("chat.conf", "r")) == NULL) {
- printf("\n#ERROR: chat.conf not found!\n");
- printf(" This file must be in your current directory.\n");
-! printf(" Using defaults...\n");
- fflush(stdout);
- return;
- }
---- 1458,1464 ----
- if ((f = fopen("chat.conf", "r")) == NULL) {
- printf("\n#ERROR: chat.conf not found!\n");
- printf(" This file must be in your current directory.\n");
-! printf(" You can find example in /usr/local/share/doc/tintin\n");
- fflush(stdout);
- return;
- }
diff --git a/net/tintin++-devel/files/patch-ac b/net/tintin++-devel/files/patch-ac
new file mode 100644
index 000000000000..964fef610a47
--- /dev/null
+++ b/net/tintin++-devel/files/patch-ac
@@ -0,0 +1,22 @@
+--- chat.c.orig Fri Sep 8 13:42:00 2000
++++ chat.c Tue Sep 23 12:46:11 2000
+@@ -66,7 +66,6 @@
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <memory.h>
+-#include <malloc.h>
+ #include <errno.h>
+ #include <ctype.h>
+ #include <sys/socket.h>
+@@ -1456,9 +1455,8 @@
+
+
+ if ((f = fopen("chat.conf", "r")) == NULL) {
+- printf("\n#ERROR: chat.conf not found!\n");
+- printf(" This file must be in your current directory.\n");
+- printf(" Using defaults...\n");
++ printf("\n#CHAT: chat.conf file must be in your current directory to enable it.\n");
++ printf(" You can find example in /usr/local/share/doc/tintin, use with caution.\n");
+ fflush(stdout);
+ return;
+ }
diff --git a/net/tintin++-devel/files/patch-ad b/net/tintin++-devel/files/patch-ad
new file mode 100644
index 000000000000..007d0b4b2796
--- /dev/null
+++ b/net/tintin++-devel/files/patch-ad
@@ -0,0 +1,11 @@
+--- scrsize.c.orig Tue Sep 23 12:10:26 2000
++++ scrsize.c Tue Sep 23 12:22:17 2000
+@@ -14,7 +14,7 @@
+
+ #ifdef HAVE_SYS_TERMIO_H
+ #include <sys/termio.h>
+-#else
++#elif !defined(HAVE_SYS_IOCTL_H)
+ #include <sgtty.h>
+ #endif
+
diff --git a/net/tintin++-devel/files/patch-ae b/net/tintin++-devel/files/patch-ae
new file mode 100644
index 000000000000..aa766ece6232
--- /dev/null
+++ b/net/tintin++-devel/files/patch-ae
@@ -0,0 +1,11 @@
+--- rl.c.orig Sun Aug 13 02:40:28 2000
++++ rl.c Tue Sep 26 13:38:02 2000
+@@ -436,7 +436,7 @@
+ /* get a clean screen without the split crap; useful for ^Z, quitting, etc */
+ void cleanscreen(void)
+ {
+- system("stty echo"); /* a hack, admittedly */
++ // system("stty echo"); /* a hack, admittedly */
+
+ if(!is_split)
+ return;