aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++-devel
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-07 20:19:15 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-07 20:19:15 +0000
commite0397ac29fc745cb68c7835889e7687b58f73f9c (patch)
tree8a395ad889a4eb65764e9470cd7c9c9aa3727b62 /net/tintin++-devel
parent59dbb8937246ebc98ff00b812ad9be1a65a116ab (diff)
downloadports-e0397ac29fc745cb68c7835889e7687b58f73f9c.tar.gz
ports-e0397ac29fc745cb68c7835889e7687b58f73f9c.zip
Notes
Diffstat (limited to 'net/tintin++-devel')
-rw-r--r--net/tintin++-devel/Makefile44
-rw-r--r--net/tintin++-devel/distinfo4
-rw-r--r--net/tintin++-devel/files/patch-aa11
-rw-r--r--net/tintin++-devel/files/patch-ab11
-rw-r--r--net/tintin++-devel/files/patch-ac14
-rw-r--r--net/tintin++-devel/files/patch-ad11
-rw-r--r--net/tintin++-devel/files/patch-ae11
-rw-r--r--net/tintin++-devel/files/patch-src__Makefile.in20
-rw-r--r--net/tintin++-devel/pkg-descr14
-rw-r--r--net/tintin++-devel/pkg-plist17
10 files changed, 56 insertions, 101 deletions
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index be176b4ec53c..ed25bd757dd9 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -6,27 +6,37 @@
#
PORTNAME= tintin
-PORTVERSION= 1.8.6b
-CATEGORIES?= net games
-MASTER_SITES= http://mail.newclear.net/tintin/download/ \
- http://freebsd.hanirc.org/~jhp/tintin++/ \
- http://www.stud.ntnu.no/~sverreno/tintin/
-DISTNAME= tintin++v1.86b
+PORTVERSION= 1.95.1
+CATEGORIES+= net games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= jhp@cocoja.holywar.net
-COMMENT= "a client program specialized to help playing muds(devel version)"
+COMMENT= A client program to help playing muds (devel version)
+
+WRKSRC= ${WRKDIR}/tt/src
-NO_LATEST_LINK= yes
-WRKSRC= ${WRKDIR}/tintin++/src
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/tt++
+PORTDOCS= BUGS CREDITS FAQ README TODO tintin19.txt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CFLAGS+= -I ${LOCALBASE}/include
+MAKE_ENV+= LIBS="-L${LOCALBASE}/lib"
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/lib/tintin
- ${INSTALL_DATA} ${WRKSRC}/support/.tt_help.txt.Z ${PREFIX}/lib/tintin
- ${MKDIR} ${PREFIX}/share/doc/tintin
- ${INSTALL_DATA} ${WRKSRC}/support/.tintinrc ${PREFIX}/share/doc/tintin/tintinrc
- ${INSTALL_DATA} ${WRKSRC}/support/tt.conf ${PREFIX}/share/doc/tintin/chat.conf.example
- cd ${WRKSRC}/.. ; ${INSTALL_DATA} CHANGES FAQ CREDITS README docs/* ${PREFIX}/share/doc/tintin
-
-.include <bsd.port.mk>
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+.for i in FAQ README TODO CREDITS BUGS docs/tintin19.txt
+ ${INSTALL_DATA} ${WRKSRC}/../${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/tintin++-devel/distinfo b/net/tintin++-devel/distinfo
index 96076dbc1881..6ee5946f7db6 100644
--- a/net/tintin++-devel/distinfo
+++ b/net/tintin++-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (tintin++v1.86b.tar.gz) = 34a5db309c3598356386447c949f201f
-SIZE (tintin++v1.86b.tar.gz) = 227194
+MD5 (tintin-1.95.1.tar.gz) = c5d116f6fa07f25a5a4206cce55e1a76
+SIZE (tintin-1.95.1.tar.gz) = 159204
diff --git a/net/tintin++-devel/files/patch-aa b/net/tintin++-devel/files/patch-aa
deleted file mode 100644
index aa97cde0b035..000000000000
--- a/net/tintin++-devel/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Feb 18 22:27:03 2001
-+++ Makefile.in Sun Feb 18 22:28:00 2001
-@@ -13,7 +13,7 @@
- MAKE = @MAKE@
-
- #this is the standard CFLAGS options, this is what most people should use
--CFLAGS = -O2 $(DEFINES) @BIG5@
-+CFLAGS += $(DEFINES) @BIG5@
-
- #this is the debugging CFLAGS options, should only be used if you want to
- #debug/code tintin
diff --git a/net/tintin++-devel/files/patch-ab b/net/tintin++-devel/files/patch-ab
deleted file mode 100644
index 4a3dd6e5623c..000000000000
--- a/net/tintin++-devel/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Sun Feb 18 22:31:06 2001
-+++ main.c Sun Feb 18 22:31:13 2001
-@@ -73,7 +73,7 @@
- int verbatim = 0;
- int prompt_on = 0;
- int funcnum = 0;
--int enable_chat = 1;
-+int enable_chat = 0;
- char homepath[1025];
- char prompt_line[BUFFER_SIZE];
-
diff --git a/net/tintin++-devel/files/patch-ac b/net/tintin++-devel/files/patch-ac
deleted file mode 100644
index 2068d684a24c..000000000000
--- a/net/tintin++-devel/files/patch-ac
+++ /dev/null
@@ -1,14 +0,0 @@
---- chat.c.orig Sun Feb 18 22:32:15 2001
-+++ chat.c Sun Feb 18 22:33:18 2001
-@@ -1451,9 +1451,8 @@
- sprintf(filestring, "%s/%s", getenv("HOME"), CONFIG_FILE);
-
- if ((f = fopen(filestring, "r")) == NULL) {
-- printf("\n#ERROR: tt.conf not found!\n");
-- printf(" This file must be in your home directory.\n");
-- printf(" Using defaults...\n");
-+ printf("\n#CHAT: chat.conf file must be in your current directory to enable it.\n");
-+ printf(" You can find example in /usr/local/share/doc/tintin, use with caution.\n");
- fflush(stdout);
- return;
- }
diff --git a/net/tintin++-devel/files/patch-ad b/net/tintin++-devel/files/patch-ad
deleted file mode 100644
index 007d0b4b2796..000000000000
--- a/net/tintin++-devel/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- scrsize.c.orig Tue Sep 23 12:10:26 2000
-+++ scrsize.c Tue Sep 23 12:22:17 2000
-@@ -14,7 +14,7 @@
-
- #ifdef HAVE_SYS_TERMIO_H
- #include <sys/termio.h>
--#else
-+#elif !defined(HAVE_SYS_IOCTL_H)
- #include <sgtty.h>
- #endif
-
diff --git a/net/tintin++-devel/files/patch-ae b/net/tintin++-devel/files/patch-ae
deleted file mode 100644
index aa766ece6232..000000000000
--- a/net/tintin++-devel/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- rl.c.orig Sun Aug 13 02:40:28 2000
-+++ rl.c Tue Sep 26 13:38:02 2000
-@@ -436,7 +436,7 @@
- /* get a clean screen without the split crap; useful for ^Z, quitting, etc */
- void cleanscreen(void)
- {
-- system("stty echo"); /* a hack, admittedly */
-+ // system("stty echo"); /* a hack, admittedly */
-
- if(!is_split)
- return;
diff --git a/net/tintin++-devel/files/patch-src__Makefile.in b/net/tintin++-devel/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..8261e711775e
--- /dev/null
+++ b/net/tintin++-devel/files/patch-src__Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Tue May 31 13:37:38 2005
++++ Makefile.in Fri Oct 7 17:08:10 2005
+@@ -32,7 +32,7 @@
+ MAKE = @MAKE@
+
+ #this is the standard CFLAGS options, this is what most people should use
+-CFLAGS = -Wall $(DEFINES) @BIG5@
++CFLAGS += -Wall $(DEFINES) @BIG5@
+
+ #this is the debugging CFLAGS options, should only be used if you want to
+ #debug/code tintin
+@@ -49,7 +49,7 @@
+ #Since readline and history are required, I'll hard code it in here.
+ #Guess we'll add zlib as well - Scandum
+
+-LIBS = @MYLIB@ -lreadline -lhistory -lz -lncurses @LIBS@
++LIBS += @MYLIB@ -lreadline -lhistory -lz -lncurses @LIBS@
+
+ # If you prefer to be able to enter ISO latin-1 characters instead
+ # of being able to use the meta key for special emacs-like commands
diff --git a/net/tintin++-devel/pkg-descr b/net/tintin++-devel/pkg-descr
index 2813eda4bb5d..e7496e069f5d 100644
--- a/net/tintin++-devel/pkg-descr
+++ b/net/tintin++-devel/pkg-descr
@@ -1,8 +1,8 @@
-TINTIN++ is a client program specialized to help playing muds.
-This is a souped up version of TINTIN III, many new features
-have been added since III. We saw room for improvement on the
-features available from TINTIN, and since we like the format of
-the program, we decided to use TINTIN as a base for what we
-hope to make one of the most powerful clients around.
+ TINTIN++ is a client program specialized to help playing muds.
+ This is a souped up version of TINTIN III, many new features
+ have been added since III. We saw room for improvement on the
+ features available from TINTIN, and since we like the format of
+ the program, we decided to use TINTIN as a base for what we
+ hope to make one of the most powerful clients around.
-WWW: http://mail.newclear.net/tintin/
+WWW: http://www.scandum.com/tintin/
diff --git a/net/tintin++-devel/pkg-plist b/net/tintin++-devel/pkg-plist
deleted file mode 100644
index d3282c38b658..000000000000
--- a/net/tintin++-devel/pkg-plist
+++ /dev/null
@@ -1,17 +0,0 @@
-bin/tt++
-lib/tintin/.tt_help.txt.Z
-share/doc/tintin/CHANGES
-share/doc/tintin/CREDITS
-share/doc/tintin/FAQ
-share/doc/tintin/MODIFICATIONS
-share/doc/tintin/MODS.ycjhi
-share/doc/tintin/README
-share/doc/tintin/chat.conf.example
-share/doc/tintin/example1.script
-share/doc/tintin/example2.script
-share/doc/tintin/sgi
-share/doc/tintin/tintin15.ps
-share/doc/tintin/tintin15.txt
-share/doc/tintin/tintinrc
-@dirrm share/doc/tintin
-@dirrm lib/tintin