aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-24 03:58:10 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-24 03:58:10 +0000
commit23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2 (patch)
treebf902918ea7c3c799ea9697638ba106fe555520d /net/tintin++
parent55eb53803480fa9e826b0dccbe9fcc7fa76d27d0 (diff)
downloadports-23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2.tar.gz
ports-23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2.zip
Notes
Diffstat (limited to 'net/tintin++')
-rw-r--r--net/tintin++/Makefile44
-rw-r--r--net/tintin++/distinfo3
-rw-r--r--net/tintin++/files/patch-configure18
-rw-r--r--net/tintin++/pkg-descr9
4 files changed, 74 insertions, 0 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
new file mode 100644
index 000000000000..c51b12ad8baf
--- /dev/null
+++ b/net/tintin++/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: tintin++
+# Date created: 15 Nov 1994
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME= tintin++
+PORTVERSION= 2.00.1
+CATEGORIES+= net games
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= tintin-${PORTVERSION}
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A client program to help playing MUDs
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+CONFIGURE_ARGS+=--includedir=${LOCALBASE}/include --libdir=${LOCALBASE}/lib \
+ --prefix=${PREFIX}
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/tt++
+PORTDOCS= ${DOCS:T}
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/tt/src
+
+DOCS= CREDITS FAQ README SCRIPTS TODO \
+ docs/chat_protocol.txt docs/tintin19.txt
+PROJECTHOST= tintin-mud-client
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC}/.. && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/tintin++/distinfo b/net/tintin++/distinfo
new file mode 100644
index 000000000000..6e303d69b63a
--- /dev/null
+++ b/net/tintin++/distinfo
@@ -0,0 +1,3 @@
+MD5 (tintin-2.00.1.tar.gz) = 5bc8d0f4df124f7fe01a5904084ae01b
+SHA256 (tintin-2.00.1.tar.gz) = 0dc1f6805a2e408e6733504310d006bc2f98bd7ff23ff365c570cdb1ac016bef
+SIZE (tintin-2.00.1.tar.gz) = 241875
diff --git a/net/tintin++/files/patch-configure b/net/tintin++/files/patch-configure
new file mode 100644
index 000000000000..29bafbbe941e
--- /dev/null
+++ b/net/tintin++/files/patch-configure
@@ -0,0 +1,18 @@
+--- ./configure.orig 2009-07-22 10:02:23.000000000 -0400
++++ ./configure 2009-07-22 10:02:40.000000000 -0400
+@@ -6176,11 +6176,11 @@
+ { { $as_echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+ $as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+ { (exit 1); exit 1; }; }
+-if test -r "/dev/ptmx"; then
+- ac_cv_file__dev_ptmx=yes
+-else
++#if test -r "/dev/ptmx"; then
++# ac_cv_file__dev_ptmx=yes
++#else
+ ac_cv_file__dev_ptmx=no
+-fi
++#fi
+ fi
+ { $as_echo "$as_me:$LINENO: result: $ac_cv_file__dev_ptmx" >&5
+ $as_echo "$ac_cv_file__dev_ptmx" >&6; }
diff --git a/net/tintin++/pkg-descr b/net/tintin++/pkg-descr
new file mode 100644
index 000000000000..e8850b1a7214
--- /dev/null
+++ b/net/tintin++/pkg-descr
@@ -0,0 +1,9 @@
+TinTin++ is a console MUD client for Windows, Linux, and Mac OS X. Its main
+assets are an easy to learn and use scripting language, full telnet support,
+a split screen interface to separate mud output from client input, and
+keyboard macros that work on all systems.
+
+TinTin++ projet is now hosted on Google Code sine version 1.99.6b1.
+
+WWW: http://tintin.sourceforge.net/
+ http://code.google.com/p/tintin-mud-client