aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2000-09-26 10:26:33 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2000-09-26 10:26:33 +0000
commit64d46dffd0a21b83ec83b6572dce3712b940090d (patch)
treeb4c1484b3a9ff199f02beeffad5979f118b16879 /net/tintin++
parent67e367a250d17aee17a54b6c15a8f784490e9221 (diff)
downloadports-64d46dffd0a21b83ec83b6572dce3712b940090d.tar.gz
ports-64d46dffd0a21b83ec83b6572dce3712b940090d.zip
Notes
Diffstat (limited to 'net/tintin++')
-rw-r--r--net/tintin++/Makefile7
-rw-r--r--net/tintin++/distinfo2
-rw-r--r--net/tintin++/files/patch-ac57
-rw-r--r--net/tintin++/files/patch-ad112
-rw-r--r--net/tintin++/pkg-descr2
5 files changed, 175 insertions, 5 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 7188e18bcaa2..e78da28cbfc8 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= tintin
-PORTVERSION= 1.5.6
+PORTVERSION= 1.5.9
CATEGORIES= net games
MASTER_SITES= ftp://ftp.walrus.com/pub/avatar/clients/ \
ftp://ftp.cctpu.edu.ru/pub/comp/networking/mud/ \
ftp://iclub.nsu.ru/pub/mud/clients/tintin++/
-DISTNAME= tintin++v1.5pl6
-EXTRACT_SUFX= .tar.Z
+DISTNAME= tintin++v1.5pl9
MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/tintin++/src
+WRKSRC= ${WRKDIR}/tintin++/v1.5/src
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/net/tintin++/distinfo b/net/tintin++/distinfo
index cf0255698251..4c49742ce444 100644
--- a/net/tintin++/distinfo
+++ b/net/tintin++/distinfo
@@ -1 +1 @@
-MD5 (tintin++v1.5pl6.tar.Z) = 35e53d661606d035c3e92a249e44160f
+MD5 (tintin++v1.5pl9.tar.gz) = 0635a327e074d83e7c4b1f70149b6b35
diff --git a/net/tintin++/files/patch-ac b/net/tintin++/files/patch-ac
new file mode 100644
index 000000000000..6e2682995667
--- /dev/null
+++ b/net/tintin++/files/patch-ac
@@ -0,0 +1,57 @@
+--- Makefile.in.orig Thu Mar 25 11:03:34 1999
++++ Makefile.in Tue Sep 26 18:07:31 2000
+@@ -10,7 +10,6 @@
+ # try uncommenting the 'gcc' line and commenting the 'cc' one.
+ # Tintin++ doesn't *need* an ANSI compiler anymore, but gcc
+ # is still better than cc on many platforms...
+-CC = @CC@ -O
+ CFLAGS = @DEFS@
+ LIBS = @LIBS@
+ PIPE = @PIPE@
+@@ -22,10 +21,10 @@
+
+ # BINDIR is the directory you wish tt++ to be placed if you wish to use
+ # make install.
+-BINDIR = ..
++BINDIR = /usr/local/bin
+
+ # DEFAULT_FILE_DIR is the path to tintin files.
+-DEFAULT_FILE_DIR = ~
++DEFAULT_FILE_DIR = /usr/local/lib/tintin
+
+ #########################################
+ # You shouldn't need to change anything #
+@@ -41,14 +40,14 @@
+ variables.c highlight.c antisub.c ivars.c help.c text.c glob.c
+ OFILES = $(CFILES:.c=.o)
+
+-all: tintin++ install
++all: tintin++
+
+ tintin++: $(OFILES) tintin.h
+ @echo "Linking..."
+ $(CC) $(CFLAGS) $(FFLAGS) $(LFLAGS) -o tt++ $(OFILES) $(LIBS)
+
+ install: all
+- @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) $(COMPRESSED_HELP)
++ @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) Ok
+
+ # Autocompile all .c files into .o files using this rule:
+ .c.o:
+--- install.sh.orig Thu Mar 25 11:13:50 1999
++++ install.sh Tue Sep 26 18:13:52 2000
+@@ -6,11 +6,12 @@
+ echo " "
+ echo "Copying the tintin++ executable to \"$1\"..."
+ #strip tt++
+-cp tt++ "$1"
++install -c -s -o bin -g bin -m 555 tt++ "$1"
+
+ echo "Copying the tintin++ help file to \"$2\"..."
+ if [ "$3" ]; then
+- cp support/.tt_help.txt.Z "$2/"
++ [ -d "$2" ] || mkdir -p "$2"
++ install -c -o bin -g bin -m 555 support/.tt_help.txt.Z "$2/"
+ fi
+
+ echo
diff --git a/net/tintin++/files/patch-ad b/net/tintin++/files/patch-ad
new file mode 100644
index 000000000000..3765c1dda3e4
--- /dev/null
+++ b/net/tintin++/files/patch-ad
@@ -0,0 +1,112 @@
+--- main.c.orig Thu Mar 25 11:26:53 1999
++++ main.c Tue Sep 26 17:27:58 2000
+@@ -18,6 +18,7 @@
+ #include <signal.h>
+ #include "tintin.h"
+ #include <fcntl.h>
++#include <termios.h>
+
+ #ifndef BADSIG
+ #define BADSIG (void (*)())-1
+@@ -109,7 +110,7 @@
+ tcflag_t c_lflag;
+ cc_t c_cc[NCCS];
+ #else
+-unsigned char c_cc[NCC];
++unsigned char c_cc[NCCS];
+ unsigned short c_lflag;
+ #endif
+
+@@ -580,7 +581,7 @@
+ if(ses->logfile) {
+ if (!OLD_LOG) {
+ count=0;
+- for(n=0;n<=didget;n++)
++ for(n=0;n<didget;n++)
+ if (buffer[n]!='\r') {
+ temp[count]=buffer[n];
+ count++;
+@@ -750,7 +751,7 @@
+ sprintf(strng,"%c8%s\n\r%c7%c[%d;%df", E, cptr, E, E, input_row, input_col);
+ else
+ sprintf(strng,"%s\n\r", cptr);
+- write(1,strng, strlen(strng)+1);
++ write(1,strng, strlen(strng));
+ display_col=1;
+ if (redraw && term_echoing && !is_split)
+ write(1, k_input, strlen(k_input));
+@@ -806,7 +807,7 @@
+ cptr++;
+ sprintf(strng,"%s\n\r", cptr);
+ }
+- write(1,strng, strlen(strng)+1);
++ write(1,strng, strlen(strng));
+ display_col=1;
+ }
+ text_came=TRUE;
+@@ -876,7 +877,7 @@
+ input_col=1;
+ sprintf(fn, "%c[2J%c[1;%dr%c[%d;1f", E, E, display_row, E, split_line);
+ write(1,fn, strlen(fn));
+- write(1,"-------------------------------------------------------------------------------", 80);
++ write(1,"--------------------------------------------------------------------------------", 80);
+ sprintf(fn, "%c[%d;1f%c7", E, split_line-1, E);
+ write(1,fn,strlen(fn));
+ sprintf(fn, "%c[%d;1f", E, input_row);
+--- misc.c.orig Fri Mar 5 21:40:11 1999
++++ misc.c Tue Sep 26 17:20:07 2000
+@@ -106,7 +106,7 @@
+ char temp[2];
+ temp[0]=7;
+ temp[1]=0;
+- write(1, temp, 2);
++ write(1, temp, 1);
+ }
+
+
+@@ -176,7 +176,7 @@
+ }
+ ses=NULL;
+ if (is_split)
+- write(1, "c", 3);
++ write(1, "c", 2);
+ tintin_puts2("TINTIN suffers from bloodlack, and the lack of a beating heart...", ses);
+ tintin_puts2("TINTIN is dead! R.I.P.", ses);
+ tintin_puts2("Your blood freezes as you hear TINTIN's death cry.", ses);
+--- parse.c.orig Sun Aug 28 22:12:10 1994
++++ parse.c Tue Sep 26 17:20:07 2000
+@@ -670,10 +670,10 @@
+ if(ses && !PSEUDO_PROMPT)
+ write_line_mud("", ses);
+ else if (!is_split)
+- write(1,"> ", 3);
++ write(1,"> ", 2);
+ else {
+ sprintf(strng,"8> 7[%d;%df", input_row, input_col);
+- write(1,strng, strlen(strng)+1);
++ write(1,strng, strlen(strng));
+ display_col+=2;
+ }
+ }
+--- utils.c.orig Fri Mar 5 00:58:57 1999
++++ utils.c Tue Sep 26 17:23:23 2000
+@@ -21,6 +21,8 @@
+ #include <unistd.h>
+ #endif
+
++#include <sys/param.h>
++
+ void syserr();
+
+ /*********************************************/
+@@ -56,7 +58,9 @@
+ char *msg;
+ {
+ extern int errno, sys_nerr;
+- //extern char *sys_errlist[];
++#if !defined(BSD) || (BSD < 199306)
++ extern char *sys_errlist[];
++#endif
+
+ fprintf(stderr,"ERROR: %s (%d",msg, errno);
+ if(errno>0 && errno<sys_nerr)
diff --git a/net/tintin++/pkg-descr b/net/tintin++/pkg-descr
index a7d66ff3c745..dd2205aa19ca 100644
--- a/net/tintin++/pkg-descr
+++ b/net/tintin++/pkg-descr
@@ -4,3 +4,5 @@
features available from TINTIN, and since we like the format of
the program, we decided to use TINTIN as a base for what we
hope to make one of the most powerful clients around.
+
+WWW: http://mail.newclear.net/tintin/index.html