aboutsummaryrefslogtreecommitdiff
path: root/net/tn3270/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-25 08:45:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-25 08:45:46 +0000
commitc630cddc43dc69dcbbecb6b6001f459aeaafd5d4 (patch)
treeea2a868c0150f917926b9067a284454f9d205c8a /net/tn3270/Makefile
parent0c439ee34f28651f4665ddbef6a4e9511df8d0b3 (diff)
Notes
Diffstat (limited to 'net/tn3270/Makefile')
-rw-r--r--net/tn3270/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/net/tn3270/Makefile b/net/tn3270/Makefile
index a89043410bdd..a526768d18c3 100644
--- a/net/tn3270/Makefile
+++ b/net/tn3270/Makefile
@@ -20,12 +20,12 @@ MAN1= tn3270.1 mset.1
MAN5= map3270.5
MANCOMPRESSED= maybe
-LIBTELNETDIR?= /usr/src/lib/libtelnet
-
-.include <bsd.port.pre.mk>
+OLD_LIBTELNETDIR= /usr/src/contrib/telnet
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+.if exists(${OLD_LIBTELNETDIR})
+LIBTELNETDIR?= /usr/src/contrib/telnet/libtelnet
+.else
+LIBTELNETDIR?= /usr/src/lib/libtelnet
.endif
post-extract:
@@ -36,6 +36,12 @@ post-extract:
exit 1; \
fi
${CP} -rp ${LIBTELNETDIR} ${WRKSRC}
+.if exists(${OLD_LIBTELNETDIR})
+ ${CP} ${LIBTELNETDIR}/../arpa/telnet.h ${WRKSRC}/libtelnet
+ ${SED} -E '/^(TELNETDIR|\.PATH|CFLAGS|INCS)/d' \
+ ${LIBTELNETDIR}/../../../lib/libtelnet/Makefile > \
+ ${WRKSRC}/libtelnet/Makefile
+.endif
do-configure:
${ECHO_CMD} "BINDIR= ${PREFIX}/bin" > ${WRKDIR}/Makefile.inc
@@ -45,4 +51,4 @@ do-build:
${MAKE} depend; \
${MAKE} all
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>