aboutsummaryrefslogtreecommitdiff
path: root/net/traff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /net/traff
parent4706739618b79681811e5b336a54032908638160 (diff)
Notes
Diffstat (limited to 'net/traff')
-rw-r--r--net/traff/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/traff/Makefile b/net/traff/Makefile
index 80c2e46cc6ad..0b84a89353d3 100644
--- a/net/traff/Makefile
+++ b/net/traff/Makefile
@@ -23,19 +23,19 @@ CFLAGS+= ${PTHREAD_CFLAGS} -L${LOCALBASE}/lib
LFLAGS= ${PTHREAD_LIBS}
CONFIGURE_ENV+= "LIBS=-largp"
-OPTIONS= MYSQL "Enable MYSQL storage" on \
- PGSQL "Enable PGSQL storage" off
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CFLAGS+= -DwithMYSQL -I${LOCALBASE}/include -L${LOCALBASE}/lib/mysql
LFLAGS+= -L${LOCALBASE}/lib/mysql -lmysqlclient_r
CONFIGURE_ARGS+=--enable-mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CFLAGS+= -DwithPGSQL -I${LOCALBASE}/include
LFLAGS+= -L${LOCALBASE}/lib -lpq
@@ -55,4 +55,4 @@ do-install:
. endif
${INSTALL_DATA} ${WRKSRC}/traff.conf ${PREFIX}/etc/traff.conf.default
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>