aboutsummaryrefslogtreecommitdiff
path: root/net/tramp
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-07-21 22:19:34 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-07-21 22:19:34 +0000
commit1e02a33001bd2118934cf43474c462632e46ee04 (patch)
tree9838524c4f188290783fa755fdf8f522821d8379 /net/tramp
parent6a027d62cd373ad75f9ab0af72c1dd77b0d07159 (diff)
downloadports-1e02a33001bd2118934cf43474c462632e46ee04.tar.gz
ports-1e02a33001bd2118934cf43474c462632e46ee04.zip
Notes
Diffstat (limited to 'net/tramp')
-rw-r--r--net/tramp/Makefile5
-rw-r--r--net/tramp/distinfo4
-rw-r--r--net/tramp/files/patch-tramp.el42
3 files changed, 4 insertions, 47 deletions
diff --git a/net/tramp/Makefile b/net/tramp/Makefile
index f14cf4490576..b5cc1f5341d8 100644
--- a/net/tramp/Makefile
+++ b/net/tramp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tramp
-PORTVERSION= 2.0.41
-PORTREVISION= 1
+PORTVERSION= 2.0.43
CATEGORIES= net elisp
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +18,7 @@ COMMENT= Transparent remote file access tool for emacsen
EMACS_PORT_NAME?= emacs21
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOCONF_VER= 259
TRAMP_LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
PLIST_SUB+= TRAMP_LISPDIR=${TRAMP_LISPDIR} \
diff --git a/net/tramp/distinfo b/net/tramp/distinfo
index 9f17512bdb38..fe538dada65a 100644
--- a/net/tramp/distinfo
+++ b/net/tramp/distinfo
@@ -1,2 +1,2 @@
-MD5 (tramp-2.0.41.tar.gz) = 2176af2ee6a0651c666b695b5508f923
-SIZE (tramp-2.0.41.tar.gz) = 285435
+MD5 (tramp-2.0.43.tar.gz) = a594c9a93239a81e8a51fe54f5a7dcbf
+SIZE (tramp-2.0.43.tar.gz) = 368387
diff --git a/net/tramp/files/patch-tramp.el b/net/tramp/files/patch-tramp.el
deleted file mode 100644
index aad7656df633..000000000000
--- a/net/tramp/files/patch-tramp.el
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: lisp/tramp.el
-===================================================================
-RCS file: /cvsroot/tramp/tramp/lisp/tramp.el,v
-retrieving revision 2.359.2.3
-retrieving revision 2.359.2.4
-diff -u -r2.359.2.3 -r2.359.2.4
---- lisp/tramp.el 29 May 2004 21:40:49 -0000 2.359.2.3
-+++ lisp/tramp.el 30 May 2004 20:55:59 -0000 2.359.2.4
-@@ -1885,6 +1885,16 @@
- ;; To be activated for debugging containing this macro
- (def-edebug-spec with-parsed-tramp-file-name t)
-
-+(defmacro tramp-let-maybe (variable value &rest body)
-+ "Let-bind VARIABLE to VALUE in BODY, but only if VARIABLE is not obsolete.
-+BODY is executed whether or not the variable is obsolete.
-+The intent is to protect against `obsolete variable' warnings."
-+ `(if (get ',variable 'byte-obsolete-variable)
-+ (progn ,@body)
-+ (let ((,variable ,value))
-+ ,@body)))
-+(put 'tramp-let-maybe 'lisp-indent-function 2)
-+
- ;;; Config Manipulation Functions:
-
- (defun tramp-set-completion-function (method function-list)
-@@ -6790,16 +6800,6 @@
- (funcall (symbol-function 'process-kill-without-query)
- process flag)))
-
--(defmacro tramp-let-maybe (variable value &rest body)
-- "Let-bind VARIABLE to VALUE in BODY, but only if VARIABLE is not obsolete.
--BODY is executed whether or not the variable is obsolete.
--The intent is to protect against `obsolete variable' warnings."
-- `(if (get 'byte-obsolete-variable ',variable)
-- (progn ,@body)
-- (let ((,variable ,value))
-- ,@body)))
--(put 'tramp-let-maybe 'lisp-indent-function 2)
--
-
- ;; ------------------------------------------------------------
- ;; -- Kludges section --