aboutsummaryrefslogtreecommitdiff
path: root/net/tridiavnc
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-05-20 19:49:17 +0000
committerCy Schubert <cy@FreeBSD.org>2011-05-20 19:49:17 +0000
commit6b0f9172cfffd1c1c1f22a8be358149487e41c63 (patch)
tree0a1019a0a5b3679488d1dc4fb96c614b57a8fc3c /net/tridiavnc
parentdd51a8bfe401524ae4a324892a7bd1ad9301b61d (diff)
downloadports-6b0f9172cfffd1c1c1f22a8be358149487e41c63.tar.gz
ports-6b0f9172cfffd1c1c1f22a8be358149487e41c63.zip
Notes
Diffstat (limited to 'net/tridiavnc')
-rw-r--r--net/tridiavnc/Makefile59
-rw-r--r--net/tridiavnc/distinfo3
-rw-r--r--net/tridiavnc/pkg-descr5
-rw-r--r--net/tridiavnc/pkg-plist18
4 files changed, 85 insertions, 0 deletions
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
new file mode 100644
index 000000000000..d2b39e6b4c36
--- /dev/null
+++ b/net/tridiavnc/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: tridiavnc
+# Date created: 14 June 2001
+# Whom: dwcjr
+#
+# $FreeBSD$
+#
+
+PORTNAME= tridiavnc
+PORTVERSION= 1.4
+PORTREVISION= 4
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=dwcjr
+DISTNAME= DevVNC_unix
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Display X and Win32 desktops on remote X/Win32/Java displays
+
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}/unix/vnc_unixsrc
+USE_IMAKE= yes
+USE_XORG= ice sm x11 xaw xext xmu xt xpm
+ALL_TARGET= World
+NO_INSTALL_MANPAGES= yes
+XFREE86_HTML_MAN= no
+
+CONFLICTS= tightvnc-[0-9]* vnc-[0-9]*
+
+.ifdef(TRIDIAVNC_BASE)
+PREFIX=${TRIDIAVNC_BASE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != i386
+BROKEN= Does not compile on ${MACHINE_ARCH}
+.endif
+
+post-patch:
+.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def Xvnc/config/cf/Imake.tmpl
+ @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}
+.endfor
+ @${PERL} -pi -e "s,/usr/local/vnc/classes,${DATADIR}/classes,g ; \
+ s,^#!/usr/bin/perl,#!${PERL},g" ${WRKSRC}/vncserver
+
+# We have to frob a few things, and we want our own permissions, so it's easier
+# to do the install ourselves.
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Xvnc/programs/Xserver/Xvnc ${PREFIX}/bin/Xvnc
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncviewer/vncviewer ${PREFIX}/bin/vncviewer
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncpasswd/vncpasswd ${PREFIX}/bin/vncpasswd
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncconnect/vncconnect ${PREFIX}/bin/vncconnect
+ ${INSTALL_SCRIPT} ${WRKSRC}/vncserver ${PREFIX}/bin/vncserver
+# Go install Java classes
+ ${MKDIR} ${PREFIX}/share/vnc
+ ${CP} -R ${WRKSRC}/classes ${PREFIX}/share/vnc
+
+.include <bsd.port.post.mk>
diff --git a/net/tridiavnc/distinfo b/net/tridiavnc/distinfo
new file mode 100644
index 000000000000..40ef3c5ef63d
--- /dev/null
+++ b/net/tridiavnc/distinfo
@@ -0,0 +1,3 @@
+MD5 (DevVNC_unix.tgz) = 209e4a0a9fffae731a560486ada554fe
+SHA256 (DevVNC_unix.tgz) = eb056b7ef92aefcf3290f8a04d73595f429ece294e390c44b052b4c54c5440d7
+SIZE (DevVNC_unix.tgz) = 2486571
diff --git a/net/tridiavnc/pkg-descr b/net/tridiavnc/pkg-descr
new file mode 100644
index 000000000000..b2a21d7a75de
--- /dev/null
+++ b/net/tridiavnc/pkg-descr
@@ -0,0 +1,5 @@
+TridiaVNC is a version of VNC with many more features and has
+optional commercial support. VNC is a multiplatform client and
+server for remotly administrating systems. It uses the RFB protocol.
+
+WWW: http://www.tridiavnc.com/
diff --git a/net/tridiavnc/pkg-plist b/net/tridiavnc/pkg-plist
new file mode 100644
index 000000000000..5ac68409b13a
--- /dev/null
+++ b/net/tridiavnc/pkg-plist
@@ -0,0 +1,18 @@
+bin/Xvnc
+bin/vncviewer
+bin/vncpasswd
+bin/vncserver
+bin/vncconnect
+share/vnc/classes/DesCipher.class
+share/vnc/classes/animatedMemoryImageSource.class
+share/vnc/classes/authenticationPanel.class
+share/vnc/classes/clipboardFrame.class
+share/vnc/classes/index.vnc
+share/vnc/classes/optionsFrame.class
+share/vnc/classes/rfbProto.class
+share/vnc/classes/shared.vnc
+share/vnc/classes/vncCanvas.class
+share/vnc/classes/vncviewer.class
+share/vnc/classes/vncviewer.jar
+@dirrm share/vnc/classes
+@dirrm share/vnc