aboutsummaryrefslogtreecommitdiff
path: root/net/tsclient/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-12-11 19:22:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-12-11 19:22:26 +0000
commit81a6ee5f75d11c12e38234301aa29ff5cc512627 (patch)
tree8a82b42024fea3f31914bbc9cbef6c0e82bd52cb /net/tsclient/Makefile
parenta74febde07aa3857620d5270567aa3561a47cbe3 (diff)
downloadports-81a6ee5f75d11c12e38234301aa29ff5cc512627.tar.gz
ports-81a6ee5f75d11c12e38234301aa29ff5cc512627.zip
Notes
Diffstat (limited to 'net/tsclient/Makefile')
-rw-r--r--net/tsclient/Makefile55
1 files changed, 37 insertions, 18 deletions
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index efb11d77288a..cd34add808cf 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -6,45 +6,64 @@
#
PORTNAME= tsclient
-PORTVERSION= 0.148
-PORTREVISION= 3
+PORTVERSION= 0.150
CATEGORIES= net gnome
-MASTER_SITES= http://www.gnomepro.com/tsclient/
+MASTER_SITES= SF
MAINTAINER= ports@thepentagon.org
COMMENT= A GNOME 2 frontend for rdesktop and vncviewer
RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
-.ifdef (WITH_TIGHTVNC)
-RUN_DEPENDS+= vncviewer:${PORTSDIR}/net/tightvnc
-.endif
-
-.ifdef (WITH_XNEST)
-RUN_DEPENDS+= Xnest:${X_NESTSERVER_PORT}
-.endif
+OPTIONS= GNOME "Build with gnome support" on \
+ TIGHTVNC "vncviewer support" off \
+ XNEST "X via Xnest support (experimental)" off
+USE_AUTOTOOLS= libtool:15 automake:19 autoconf:261
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui
+USE_GNOME= gtk20
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= tsclient.1
+PORTDOCS= COPYING NEWS README
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GNOME)
+USE_GNOME+= gnomeprefix gnomehack libgnomeui
+.else
+CONFIGURE_ARGS+= --disable-gnome
+.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " set WITH_TIGHTVNC for vncviewer support"
- @${ECHO_MSG} " set WITH_XNEST for X via Xnest support (experimental)"
- @${ECHO_MSG} ""
+.if defined(WITH_TIGHTVNC)
+RUN_DEPENDS+= vncviewer:${PORTSDIR}/net/tightvnc
+.endif
+
+.if defined(WITH_XNEST)
+RUN_DEPENDS+= Xnest:${X_NESTSERVER_PORT}
+.endif
post-patch:
+ @${REINPLACE_CMD} -e '/applet/d' \
+ ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/ s,applet ,,g' \
+ -e '/^man1dir *=/ s,datadir,prefix,g' \
+ ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/aclocal.m4
post-install:
@${LN} -sf ${PREFIX}/share/pixmaps/tsclient/tsclient.png \
${PREFIX}/share/pixmaps/tsclient.png
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+. endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>