aboutsummaryrefslogtreecommitdiff
path: root/net/tsocks
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-12-19 02:17:30 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-12-19 02:17:30 +0000
commit46bdb81107d91a0d9b14ec126bde59114db1aa75 (patch)
treeb691cbbefdcf080863e7bc603ef7df629e104a43 /net/tsocks
parente21d3ab40926c754c0b3e5344afabc47969de816 (diff)
downloadports-46bdb81107d91a0d9b14ec126bde59114db1aa75.tar.gz
ports-46bdb81107d91a0d9b14ec126bde59114db1aa75.zip
Notes
Diffstat (limited to 'net/tsocks')
-rw-r--r--net/tsocks/Makefile3
-rw-r--r--net/tsocks/files/patch-tsocks.c19
2 files changed, 21 insertions, 1 deletions
diff --git a/net/tsocks/Makefile b/net/tsocks/Makefile
index 5bf388b92cbd..6ddc46554b93 100644
--- a/net/tsocks/Makefile
+++ b/net/tsocks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tsocks
PORTVERSION= 1.8.b5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.8%20beta%205 \
http://ftp1.sourceforge.net/tsocks/ \
@@ -45,5 +45,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/*.example ${STAGEDIR}${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/INSTALL ${STAGEDIR}${DOCSDIR}/README
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so
.include <bsd.port.mk>
diff --git a/net/tsocks/files/patch-tsocks.c b/net/tsocks/files/patch-tsocks.c
new file mode 100644
index 000000000000..7d5b4984dbdd
--- /dev/null
+++ b/net/tsocks/files/patch-tsocks.c
@@ -0,0 +1,19 @@
+--- tsocks.c.orig 2014-12-19 02:01:24 UTC
++++ tsocks.c
+@@ -852,7 +852,7 @@ static int connect_server(struct connreq
+ sizeof(conn->serveraddr));
+
+ show_msg(MSGDEBUG, "Connect returned %d, errno is %d\n", rc, errno);
+- if (rc) {
++ if (rc && errno != EISCONN) {
+ if (errno != EINPROGRESS) {
+ show_msg(MSGERR, "Error %d attempting to connect to SOCKS "
+ "server (%s)\n", errno, strerror(errno));
+@@ -862,6 +862,7 @@ static int connect_server(struct connreq
+ conn->state = CONNECTING;
+ }
+ } else {
++ rc = 0;
+ show_msg(MSGDEBUG, "Socket %d connected to SOCKS server\n", conn->sockid);
+ conn->state = CONNECTED;
+ }