aboutsummaryrefslogtreecommitdiff
path: root/net/ttlscan/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-05-15 13:39:13 +0000
committerMichael Landin <mich@FreeBSD.org>2003-05-15 13:39:13 +0000
commit306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c (patch)
tree30fa4b57914d7dc70fe5f9be3585d482a3e9825c /net/ttlscan/Makefile
parent09bbd91bf7c187a33703620c55c76ae932689c94 (diff)
downloadports-306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c.tar.gz
ports-306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c.zip
Notes
Diffstat (limited to 'net/ttlscan/Makefile')
-rw-r--r--net/ttlscan/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/ttlscan/Makefile b/net/ttlscan/Makefile
new file mode 100644
index 000000000000..4aa3016b65c8
--- /dev/null
+++ b/net/ttlscan/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: ttlscan
+# Date created: Wed Apr 2, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttlscan
+PORTVERSION= 0.1.1
+CATEGORIES= net
+MASTER_SITES= http://www.raisdorf.net/files/code/
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= A tcp based scanner, showing ttl responses
+
+BUILD_DEPENDS= ${LOCALBASE}/include/dnet.h:${PORTSDIR}/net/libdnet
+
+LDFLAGS+= -lpcap -ldnet
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -D_XOPEN_SOURCE \
+ `libnet-config --defines` ${PORTNAME}.c -o ${PORTNAME} `libnet-config --libs` ${LDFLAGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>