aboutsummaryrefslogtreecommitdiff
path: root/net/ttlscan
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/ttlscan
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net/ttlscan')
-rw-r--r--net/ttlscan/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/ttlscan/Makefile b/net/ttlscan/Makefile
index 3b192bcc0744..19ce50d55220 100644
--- a/net/ttlscan/Makefile
+++ b/net/ttlscan/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ttlscan
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.wormulon.net/files/ttlscan/
@@ -16,13 +16,15 @@ MAINTAINER= mich@FreeBSD.org
COMMENT= A tcp based scanner, showing ttl responses
BUILD_DEPENDS= ${LOCALBASE}/include/dnet.h:${PORTSDIR}/net/libdnet \
- libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+ ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
LDFLAGS+= -lpcap -ldnet
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -D_XOPEN_SOURCE \
- `libnet-config --defines` ${PORTNAME}.c -o ${PORTNAME} `libnet-config --libs` ${LDFLAGS})
+ `${LIBNET_CONFIG} --defines --cflags` ${PORTNAME}.c -o ${PORTNAME} `${LIBNET_CONFIG} --libs` ${LDFLAGS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin