aboutsummaryrefslogtreecommitdiff
path: root/net/ttlscan
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-05-15 13:39:13 +0000
committerMichael Landin <mich@FreeBSD.org>2003-05-15 13:39:13 +0000
commit306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c (patch)
tree30fa4b57914d7dc70fe5f9be3585d482a3e9825c /net/ttlscan
parent09bbd91bf7c187a33703620c55c76ae932689c94 (diff)
downloadports-306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c.tar.gz
ports-306ade8d75bfa2769d5e1dd3e5b25ebc416ba81c.zip
Notes
Diffstat (limited to 'net/ttlscan')
-rw-r--r--net/ttlscan/Makefile33
-rw-r--r--net/ttlscan/distinfo1
-rw-r--r--net/ttlscan/pkg-descr12
-rw-r--r--net/ttlscan/pkg-plist3
4 files changed, 49 insertions, 0 deletions
diff --git a/net/ttlscan/Makefile b/net/ttlscan/Makefile
new file mode 100644
index 000000000000..4aa3016b65c8
--- /dev/null
+++ b/net/ttlscan/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: ttlscan
+# Date created: Wed Apr 2, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttlscan
+PORTVERSION= 0.1.1
+CATEGORIES= net
+MASTER_SITES= http://www.raisdorf.net/files/code/
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= A tcp based scanner, showing ttl responses
+
+BUILD_DEPENDS= ${LOCALBASE}/include/dnet.h:${PORTSDIR}/net/libdnet
+
+LDFLAGS+= -lpcap -ldnet
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -D_XOPEN_SOURCE \
+ `libnet-config --defines` ${PORTNAME}.c -o ${PORTNAME} `libnet-config --libs` ${LDFLAGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ttlscan/distinfo b/net/ttlscan/distinfo
new file mode 100644
index 000000000000..86162585233b
--- /dev/null
+++ b/net/ttlscan/distinfo
@@ -0,0 +1 @@
+MD5 (ttlscan-0.1.1.tar.gz) = 2951a7ca5a1efef74215f6a54c67abb5
diff --git a/net/ttlscan/pkg-descr b/net/ttlscan/pkg-descr
new file mode 100644
index 000000000000..c471143177bb
--- /dev/null
+++ b/net/ttlscan/pkg-descr
@@ -0,0 +1,12 @@
+ttlscan is a libnet/libpcap based program that sends a TCP SYN packet to
+each port of the host given via the command line. The answer is sniffed
+of the wire. I use it to detect hosts that fake services by forwarding
+packets to another host (behind a firewall). By reading header files
+like the TTL, window size and IPID you might be able to see the OS
+running on the host behind the firewall.
+
+WWW: http://www.raisdorf.net/projects/ttlscan
+AUTHOR: Hendrik Scholz <hendrik@scholz.net>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/net/ttlscan/pkg-plist b/net/ttlscan/pkg-plist
new file mode 100644
index 000000000000..8b947910f075
--- /dev/null
+++ b/net/ttlscan/pkg-plist
@@ -0,0 +1,3 @@
+bin/ttlscan
+%%PORTDOCS%%share/doc/ttlscan/README
+%%PORTDOCS%%@dirrm /share/doc/ttlscan