aboutsummaryrefslogtreecommitdiff
path: root/net/ttt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-09-07 10:10:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-09-07 10:10:11 +0000
commitad3dff30b7c4b25052900b3c6adb896ccc027305 (patch)
tree48d358dc6d4f9244ae12e6ee7d16091536ac8530 /net/ttt
parent61f9142ed6b705e9382824d87f1da0cbaa1e4c95 (diff)
downloadports-ad3dff30b7c4b25052900b3c6adb896ccc027305.tar.gz
ports-ad3dff30b7c4b25052900b3c6adb896ccc027305.zip
Notes
Diffstat (limited to 'net/ttt')
-rw-r--r--net/ttt/Makefile35
-rw-r--r--net/ttt/distinfo2
-rw-r--r--net/ttt/files/patch-net_names.c21
-rw-r--r--net/ttt/files/patch-net_read.c17
-rw-r--r--net/ttt/files/patch-node.c20
-rw-r--r--net/ttt/pkg-descr15
-rw-r--r--net/ttt/pkg-plist5
7 files changed, 0 insertions, 115 deletions
diff --git a/net/ttt/Makefile b/net/ttt/Makefile
deleted file mode 100644
index 1421233d73e7..000000000000
--- a/net/ttt/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# New ports collection makefile for: ttt
-# Date created: 22 September 1998
-# Whom: Kenjiro Cho <kjc@csl.sony.co.jp>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ttt
-PORTVERSION= 1.8.2
-PORTREVISION= 3
-CATEGORIES= net tk ipv6
-MASTER_SITES= ftp://ftp.csl.sony.co.jp/pub/kjc/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Tele Traffic Tapper, a network traffic monitoring tool
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-BROKEN= Does not fetch
-
-LIB_DEPENDS= BLT24:${PORTSDIR}/x11-toolkits/blt
-
-USE_TK= 84+
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER} \
- --with-tk=${LOCALBASE}/lib/tk${TK_VER}
-INSTALL_TARGET= install install-man
-MAN1= ttt.1 tttprobe.1 tttview.1
-
-post-configure:
- ${REINPLACE_CMD} 's|^CFLAGS *=.*|CFLAGS=${CFLAGS}|' \
- ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
diff --git a/net/ttt/distinfo b/net/ttt/distinfo
deleted file mode 100644
index 3e5595e645f7..000000000000
--- a/net/ttt/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ttt-1.8.2.tar.gz) = 15ae1d935d9461b7f73ab1c06ed789ccc77f166c71c705a56191378dbcb14c03
-SIZE (ttt-1.8.2.tar.gz) = 138877
diff --git a/net/ttt/files/patch-net_names.c b/net/ttt/files/patch-net_names.c
deleted file mode 100644
index 3221c40ea399..000000000000
--- a/net/ttt/files/patch-net_names.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- net_names.c.orig 2004-08-14 14:32:15.000000000 +0200
-+++ net_names.c 2007-10-02 00:07:03.000000000 +0200
-@@ -161,6 +161,9 @@
- return NULL;
- }
-
-+static char *inet6_ntoa(uint32_t *addr); /* should be replaced by addr2ascii */
-+
-+
- char *net_getname(long type, long *id)
- {
- char *buf, *name;
-@@ -261,8 +264,6 @@
- case TTTTYPE_IPV6HOST:
- {
- u_int32_t tmp[4];
-- static char *inet6_ntoa(u_int32_t *addr); /* should be replaced
-- by addr2ascii */
- if ((buf = malloc(sizeof("xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx")))
- == NULL)
- fatal_error("get_protoname: no memory\n");
diff --git a/net/ttt/files/patch-net_read.c b/net/ttt/files/patch-net_read.c
deleted file mode 100644
index 3f533b0b4732..000000000000
--- a/net/ttt/files/patch-net_read.c
+++ /dev/null
@@ -1,17 +0,0 @@
-
- Included patch fixes the problem
-
---- patch-net_read.c begins here ---
---- net_read.c.orig Tue May 29 11:16:23 2007
-+++ net_read.c Tue May 29 11:16:48 2007
-@@ -58,6 +58,7 @@
- #include <sys/socket.h>
- #include <sys/ioctl.h>
- #include <net/if.h>
-+#include <net/bpf.h>
- #ifdef __OpenBSD__
- #include <net/if_pflog.h>
- #endif
---- patch-net_read.c ends here ---
-
-
diff --git a/net/ttt/files/patch-node.c b/net/ttt/files/patch-node.c
deleted file mode 100644
index e06d07bb7047..000000000000
--- a/net/ttt/files/patch-node.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- node.c.orig 2004-05-19 12:20:44.000000000 +0200
-+++ node.c 2007-10-02 00:27:29.000000000 +0200
-@@ -89,7 +89,7 @@
- static int b_collectgarbage(int tab_no);
- static int b_countfree(int tab_no);
- static struct t_node *b_getfree(int tab_no);
--static int fls(int i);
-+int fls(int i);
- #ifdef IPV6
- static int node_comp_id(long *a, long *b);
- #endif
-@@ -599,7 +599,7 @@
- }
-
- /* fls - find last set bit --- reverse function of vax ffs */
--static int fls(int i)
-+ int fls(int i)
- {
- int index;
-
diff --git a/net/ttt/pkg-descr b/net/ttt/pkg-descr
deleted file mode 100644
index 25d2086aa995..000000000000
--- a/net/ttt/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
- TTT: Tele Traffic Tapper
-
-ttt is yet another descendant of tcpdump but it is capable of real-time,
-graphical, and remote traffic-monitoring. ttt won't replace tcpdump,
-rather, it helps you find out what to look into with tcpdump.
-
-Features:
- - Automatic Ranking of Protocols and Hosts
- - Real-Time Monitoring
- - Remote Monitoring with IP-Multicast support
- - IPv6 Aware: (experimental)
- - Portable
- - Easy to customize
-
-WWW: http://www.sonycsl.co.jp/~kjc/software.html#ttt
diff --git a/net/ttt/pkg-plist b/net/ttt/pkg-plist
deleted file mode 100644
index 57f9308c80fc..000000000000
--- a/net/ttt/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/ttt
-bin/tttprobe
-bin/tttview
-lib/ttt/ttt.tcl
-@dirrm lib/ttt