aboutsummaryrefslogtreecommitdiff
path: root/net/tucan
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-06 17:02:32 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-06 17:02:32 +0000
commit6924611d69c5cdc88b031f82297eb34c80e94e21 (patch)
tree0b6d21cbe2053c63a1ce996d7e6574fc050b4646 /net/tucan
parente05b54307d487b318d4383baa5dc66a3c4194287 (diff)
downloadports-6924611d69c5cdc88b031f82297eb34c80e94e21.tar.gz
ports-6924611d69c5cdc88b031f82297eb34c80e94e21.zip
Notes
Diffstat (limited to 'net/tucan')
-rw-r--r--net/tucan/Makefile7
-rw-r--r--net/tucan/files/patch-core__dependencies.py11
-rw-r--r--net/tucan/files/patch-core__tesseract.py15
3 files changed, 29 insertions, 4 deletions
diff --git a/net/tucan/Makefile b/net/tucan/Makefile
index 1448b46c3145..ec388eed2094 100644
--- a/net/tucan/Makefile
+++ b/net/tucan/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tucan
PORTVERSION= 0.3.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://forja.rediris.es/frs/download.php/2051/ \
http://build-tucan-doc.googlecode.com/files/
@@ -11,14 +11,13 @@ MASTER_SITES= http://forja.rediris.es/frs/download.php/2051/ \
MAINTAINER= gustau.perez@gmail.com
COMMENT= Tucan Manager aids file-sharing with 1-click hosters
-RUN_DEPENDS= ${LOCALBASE}/bin/pilconvert.py:${PORTSDIR}/graphics/py-imaging \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
${LOCALBASE}/bin/cntraining:${PORTSDIR}/graphics/tesseract
NO_BUILD= yes
USE_GNOME= pygtk2 librsvg2
-USE_PYTHON= yes
-USES= gettext
+USES= gettext python
post-patch:
${REINPLACE_CMD} -Ee 's|#! /usr/bin/env python|#! ${PYTHON_CMD}|' ${WRKSRC}/tucan.py
diff --git a/net/tucan/files/patch-core__dependencies.py b/net/tucan/files/patch-core__dependencies.py
new file mode 100644
index 000000000000..e2925392d1c3
--- /dev/null
+++ b/net/tucan/files/patch-core__dependencies.py
@@ -0,0 +1,11 @@
+--- core/dependencies.py.orig 2014-10-06 16:41:03 UTC
++++ core/dependencies.py
+@@ -55,7 +55,7 @@
+ """"""
+ self.checked[cons.DEPENDENCY_TESSERACT] = None
+ try:
+- import Image
++ from PIL import Image
+ except:
+ message = "PIL not found."
+ self.checked[cons.DEPENDENCY_TESSERACT] = message
diff --git a/net/tucan/files/patch-core__tesseract.py b/net/tucan/files/patch-core__tesseract.py
new file mode 100644
index 000000000000..01fe1bec6678
--- /dev/null
+++ b/net/tucan/files/patch-core__tesseract.py
@@ -0,0 +1,15 @@
+--- core/tesseract.py.orig 2014-10-06 16:41:31 UTC
++++ core/tesseract.py
+@@ -26,9 +26,9 @@
+ import subprocess
+ import tempfile
+
+-import ImageFile
+-import Image
+-import TiffImagePlugin
++from PIL import ImageFile
++from PIL import Image
++from PIL import TiffImagePlugin
+
+ import cons
+