aboutsummaryrefslogtreecommitdiff
path: root/net/turnserver
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-29 22:40:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-29 22:40:57 +0000
commit7b61b3df9d3bd7c3d74309bb7f57baf450effd68 (patch)
treeedabc3773f34adc108ad61789dc3473fad3d5da7 /net/turnserver
parentef05ee043b3955a99ef3d10c6bea608510d4ac2b (diff)
downloadports-7b61b3df9d3bd7c3d74309bb7f57baf450effd68.tar.gz
ports-7b61b3df9d3bd7c3d74309bb7f57baf450effd68.zip
Notes
Diffstat (limited to 'net/turnserver')
-rw-r--r--net/turnserver/Makefile66
-rw-r--r--net/turnserver/distinfo4
-rw-r--r--net/turnserver/files/pkg-message.in24
-rw-r--r--net/turnserver/pkg-plist11
4 files changed, 46 insertions, 59 deletions
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index b2b075735093..61e139ae1254 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= turnserver
-PORTVERSION= 3.2.5.2
+PORTVERSION= 3.2.5.3
CATEGORIES= net
MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/:prog \
http://turnserver.open-sys.org/downloads/extradocs/:xdocs \
@@ -41,44 +41,46 @@ REDIS_DESC= Redis support for user database and for status and statistics report
OPTIONS_DEFAULT= MYSQL PGSQL REDIS
-.include <bsd.port.options.mk>
-
-PORTDOCS= html TURNServerRESTAPI.pdf TurnNetworks.pdf
+DOCS= html TURNServerRESTAPI.pdf TurnNetworks.pdf
PORTREADMEDOCS= LICENSE README.turnserver README.turnadmin README.turnutils INSTALL
+PORTDOCS= ${DOCS} ${PORTREADMEDOCS} postinstall.txt schema.sql \
+ schema.userdb.redis schema.stats.redis
_BIN_UTILS= peer stunclient uclient
_ETC_EXAMPLES= turnserver.conf turnuserdb.conf turn_client_cert.pem \
turn_client_pkey.pem turn_server_cert.pem turn_server_pkey.pem
_SCRIPT_EXAMPLES= peer.sh \
-basic/relay.sh basic/dos_attack.sh \
-basic/tcp_client_c2c_tcp_relay.sh basic/udp_c2c_client.sh \
-basic/udp_client.sh basic/tcp_client.sh \
-loadbalance/master_relay.sh loadbalance/slave_relay_1.sh loadbalance/slave_relay_2.sh \
-loadbalance/udp_c2c.sh loadbalance/tcp_c2c_tcp_relay.sh \
-longtermsecure/secure_dtls_client.sh longtermsecure/secure_relay.sh \
-longtermsecure/secure_tls_client_cert.sh longtermsecure/secure_dtls_client_cert.sh \
-longtermsecure/secure_relay_cert.sh \
-longtermsecure/secure_tcp_client_c2c_tcp_relay.sh longtermsecure/secure_tcp_client.sh \
-longtermsecure/secure_tls_client_c2c_tcp_relay.sh longtermsecure/secure_tls_client.sh \
-longtermsecure/secure_udp_c2c.sh longtermsecure/secure_udp_client.sh \
-longtermsecure/secure_dos_attack.sh longtermsecure/secure_udp_client.sh \
-longtermsecuredb/secure_relay_with_db_psql.sh longtermsecuredb/secure_relay_with_db_mysql.sh \
-longtermsecuredb/secure_relay_with_db_mysql_ssl.sh \
-longtermsecuredb/secure_relay_with_db_redis.sh \
-restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_mysql.sh \
-restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_redis.sh \
-restapi/secure_udp_client_with_secret.sh \
-restapi/secure_relay_secret_with_db_psql.sh \
-restapi/shared_secret_maintainer.pl \
-shorttermsecure/secure_tcp_client_c2c_tcp_relay_short_term.sh \
-shorttermsecure/secure_udp_client_short_term.sh \
-shorttermsecure/secure_relay_short_term_mech.sh \
-selfloadbalance/secure_dos_attack.sh \
-selfloadbalance/secure_relay.sh
+ basic/relay.sh basic/dos_attack.sh \
+ basic/tcp_client_c2c_tcp_relay.sh basic/udp_c2c_client.sh \
+ basic/udp_client.sh basic/tcp_client.sh \
+ loadbalance/master_relay.sh loadbalance/slave_relay_1.sh loadbalance/slave_relay_2.sh \
+ loadbalance/udp_c2c.sh loadbalance/tcp_c2c_tcp_relay.sh \
+ longtermsecure/secure_dtls_client.sh longtermsecure/secure_relay.sh \
+ longtermsecure/secure_tls_client_cert.sh longtermsecure/secure_dtls_client_cert.sh \
+ longtermsecure/secure_relay_cert.sh \
+ longtermsecure/secure_tcp_client_c2c_tcp_relay.sh longtermsecure/secure_tcp_client.sh \
+ longtermsecure/secure_tls_client_c2c_tcp_relay.sh longtermsecure/secure_tls_client.sh \
+ longtermsecure/secure_udp_c2c.sh longtermsecure/secure_udp_client.sh \
+ longtermsecure/secure_dos_attack.sh longtermsecure/secure_udp_client.sh \
+ longtermsecuredb/secure_relay_with_db_psql.sh longtermsecuredb/secure_relay_with_db_mysql.sh \
+ longtermsecuredb/secure_relay_with_db_mysql_ssl.sh \
+ longtermsecuredb/secure_relay_with_db_redis.sh \
+ restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_mysql.sh \
+ restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_redis.sh \
+ restapi/secure_udp_client_with_secret.sh \
+ restapi/secure_relay_secret_with_db_psql.sh \
+ restapi/shared_secret_maintainer.pl \
+ shorttermsecure/secure_tcp_client_c2c_tcp_relay_short_term.sh \
+ shorttermsecure/secure_udp_client_short_term.sh \
+ shorttermsecure/secure_relay_short_term_mech.sh \
+ selfloadbalance/secure_dos_attack.sh \
+ selfloadbalance/secure_relay.sh
CONFIGURE_ENV+= PTHREAD_LIBS=-pthread TURN_DISABLE_RPATH=1
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MPGSQL}
USES+= pgsql
.else
@@ -137,7 +139,7 @@ do-install:
.endif
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
+.for f in ${DOCS}
(cd ${WRKSRC}/../turndocs/docs/ && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${DOCSDIR})
.endfor
.for f in ${PORTREADMEDOCS}
@@ -147,12 +149,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/turndb/schema.sql ${STAGEDIR}${DOCSDIR}/schema.sql
${INSTALL_DATA} ${WRKSRC}/turndb/schema.userdb.redis ${STAGEDIR}${DOCSDIR}/schema.userdb.redis
${INSTALL_DATA} ${WRKSRC}/turndb/schema.stats.redis ${STAGEDIR}${DOCSDIR}/schema.stats.redis
-PORTDOCS+= postinstall.txt ${PORTREADMEDOCS} schema.sql schema.userdb.redis schema.stats.redis
.endif
-post-install:
- ${CAT} ${PKGMESSAGE}
-
regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test)
diff --git a/net/turnserver/distinfo b/net/turnserver/distinfo
index e0662292f7c8..8703a3a36a0b 100644
--- a/net/turnserver/distinfo
+++ b/net/turnserver/distinfo
@@ -1,4 +1,4 @@
-SHA256 (turnserver-3.2.5.2.tar.gz) = 1a53d38dfd22cc27bf77f6682077a20b42740a599a278fff4864a06d33d18c43
-SIZE (turnserver-3.2.5.2.tar.gz) = 307252
+SHA256 (turnserver-3.2.5.3.tar.gz) = 850260ec71c543000dfbd7dce80bf34dec74e22fea8d7ddc45b1447337dd7611
+SIZE (turnserver-3.2.5.3.tar.gz) = 307986
SHA256 (turn.extra.docs-2.0.0.1.tar.gz) = 3a86600fd0a30ce7aeb547e80402ce68ea9959f7dd58697e5b47fda6e33ab9ce
SIZE (turn.extra.docs-2.0.0.1.tar.gz) = 485379
diff --git a/net/turnserver/files/pkg-message.in b/net/turnserver/files/pkg-message.in
index cf4abfaf4a01..8604c781f09e 100644
--- a/net/turnserver/files/pkg-message.in
+++ b/net/turnserver/files/pkg-message.in
@@ -1,14 +1,14 @@
==================================================================
1) You can start and stop the turnserver manually. But, if you want
-to enable turnserver as an automatically started system service,
+to enable turnserver as an automatically started system service,
you have to:
- a) Create and edit /etc/turnserver.conf file.
+ a) Create and edit %%PREFIX%%/etc/turnserver.conf file.
Use %%PREFIX%%/etc/turnserver.conf.default as an example.
- b) For user accounts settings, if using the turnserver
- with authentication: create and edit /etc/turnuserdb.conf
+ b) For user accounts settings, if using the turnserver
+ with authentication: create and edit %%PREFIX%%/etc/turnuserdb.conf
file, or set up PostgreSQL or MySQL or Redis database for user accounts.
Use %%PREFIX%%/etc/turnuserdb.conf.default as example for flat file DB,
or use %%DATADIR%%/schema.sql as database schema,
@@ -20,21 +20,21 @@ you have to:
e) If you are using a non-default PREFIX (other than /usr/local),
then edit /usr/local/etc/rc.d/turnserver file, according to
your system settings.
-
+
f) Restart the system or run the command:
$ %%PREFIX%%/etc/rc.d/turnserver start
-
-2) If you do not want the turnserver to be a system service,
- then you can start/stop it "manually", using the "turnserver"
+
+2) If you do not want the turnserver to be a system service,
+ then you can start/stop it "manually", using the "turnserver"
executable with appropriate options (see the documentation).
-
+
3) To create database schema, use schema in file %%DATADIR%%/schema.sql.
-
+
4) For additional information, run:
-
+
$ man turnserver
$ man turnadmin
$ man turnutils
-
+
==================================================================
diff --git a/net/turnserver/pkg-plist b/net/turnserver/pkg-plist
index ff1cc3ba78e0..10103744225a 100644
--- a/net/turnserver/pkg-plist
+++ b/net/turnserver/pkg-plist
@@ -17,14 +17,12 @@ man/man1/rfc5766-turn-server.1.gz
%%DATADIR%%/schema.userdb.redis
%%DATADIR%%/schema.stats.redis
%%DATADIR%%/testredisdbsetup.sh
-@dir %%DATADIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turnserver.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turnuserdb.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_client_cert.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_client_pkey.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_server_cert.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_server_pkey.pem
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/etc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/readme.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/peer.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/basic/relay.sh
@@ -65,15 +63,6 @@ man/man1/rfc5766-turn-server.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shorttermsecure/secure_relay_short_term_mech.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/selfloadbalance/secure_dos_attack.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/selfloadbalance/secure_relay.sh
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/basic
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/loadbalance
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/longtermsecure
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/longtermsecuredb
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/restapi
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/shorttermsecure
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/selfloadbalance
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%
include/turn/ns_turn_defs.h
include/turn/client/TurnMsgLib.h
include/turn/client/ns_turn_ioaddr.h