aboutsummaryrefslogtreecommitdiff
path: root/net/udpxy/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-03-03 12:56:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-03-03 12:56:15 +0000
commitb2dcd7927c415db235d12ae921d35c3e57779584 (patch)
tree9b47606be4df16d47655e2b06e949876ce23056c /net/udpxy/Makefile
parent88be83645d3d1fd15b3db7c16b84b0a8be575681 (diff)
Notes
Diffstat (limited to 'net/udpxy/Makefile')
-rw-r--r--net/udpxy/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/udpxy/Makefile b/net/udpxy/Makefile
index 52556fed8c52..262c0c3414bc 100644
--- a/net/udpxy/Makefile
+++ b/net/udpxy/Makefile
@@ -18,10 +18,9 @@ GH_ACCOUNT= pcherenkov
WRKSRC_SUBDIR= chipmunk
OPTIONS_SINGLE= CONF
-OPTIONS_SINGLE_CONF= RELEASE LEAN DEBUG
+OPTIONS_SINGLE_CONF= RELEASE LEAN
RELEASE_DESC= No asserts, no debug symbols, verbose on
LEAN_DESC= No asserts, no debug symbols, verbose off
-DEBUG_DESC= Asserts, debug symbols, verbose on
OPTIONS_DEFAULT= RELEASE
PLIST_FILES= sbin/udpxy \
@@ -39,13 +38,12 @@ post-install:
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MRELEASE}
+.if defined(WITH_DEBUG)
+ALL_TARGET=debug
+.elif ${PORT_OPTIONS:MRELEASE}
ALL_TARGET=release
.elif ${PORT_OPTIONS:MLEAN}
ALL_TARGET=lean
-.elif ${PORT_OPTIONS:MDEBUG}
-ALL_TARGET=debug
-WITH_DEBUG=yes
.endif
.include <bsd.port.mk>