aboutsummaryrefslogtreecommitdiff
path: root/net/udt
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /net/udt
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
Notes
Diffstat (limited to 'net/udt')
-rw-r--r--net/udt/Makefile2
-rw-r--r--net/udt/files/BSDmakefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/udt/Makefile b/net/udt/Makefile
index c61eee7eadb6..b2a5069ed8dc 100644
--- a/net/udt/Makefile
+++ b/net/udt/Makefile
@@ -26,7 +26,7 @@ post-build:
# Building sample applications:
.for a in ${UDT_APPS}
${CXX} ${CXXFLAGS} ${WRKSRC:H}/app/$a.cpp -o ${WRKSRC:H}/app/udt-$a \
- -I${WRKSRC} -L${WRKSRC} -ludt
+ -I${WRKSRC} -L${WRKSRC} -ludt -pthread
.endfor
.include <bsd.port.options.mk>
diff --git a/net/udt/files/BSDmakefile b/net/udt/files/BSDmakefile
index c0d5c5111ca5..7625197ad218 100644
--- a/net/udt/files/BSDmakefile
+++ b/net/udt/files/BSDmakefile
@@ -6,7 +6,7 @@ LIBDIR= ${PREFIX}/lib
INCLUDEDIR= ${PREFIX}/include
INCS= udt.h
-LDADD= -lmd -lpthread
+LDADD= -lmd -pthread
SRCS= common.cpp window.cpp list.cpp buffer.cpp packet.cpp channel.cpp \
queue.cpp ccc.cpp cache.cpp core.cpp epoll.cpp api.cpp