aboutsummaryrefslogtreecommitdiff
path: root/net/unison-devel/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-29 09:38:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-29 09:38:57 +0000
commit3ae4fe6da729d668a82e3c814b6ff8d49df0d678 (patch)
tree873ea15d35b093b6d542ae621b2ded0e4d3c64c5 /net/unison-devel/Makefile
parent4ae045f484b3d1e1082f4f4e4eea9a56f3d992f1 (diff)
downloadports-3ae4fe6da729d668a82e3c814b6ff8d49df0d678.tar.gz
ports-3ae4fe6da729d668a82e3c814b6ff8d49df0d678.zip
Notes
Diffstat (limited to 'net/unison-devel/Makefile')
-rw-r--r--net/unison-devel/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 2e7e212bc6f5..da8e0ccaad98 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -28,7 +28,6 @@ OPTIONS_DEFAULT= DOCS X11
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= unison all
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -54,6 +53,7 @@ MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
PATCH_DEPENDS+= ${BUILD_DEPENDS}
+PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
.endif
.if ${PORT_OPTIONS:MX11}
@@ -69,26 +69,21 @@ post-build:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unison ${STAGEDIR}${PREFIX}/bin
post-install:
.if ${PORT_OPTIONS:MX11}
- @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
- cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${STAGEDIR}${PREFIX}/bin
.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
.if ${PORT_OPTIONS:MX11}
- @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
- @${MKDIR} ${DESKTOPDIR}
- @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${DESKTOPDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
@-update-desktop-database > /dev/null
- @${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
- @${CAT} ${PKGMESSAGE}
-.else
- @${CAT} ${PKGMESSAGE}.nox11
+ @${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.endif
.include <bsd.port.mk>