aboutsummaryrefslogtreecommitdiff
path: root/net/unison-devel/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-06-02 17:40:16 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-06-02 17:40:16 +0000
commitc9d7f519ed4d3020862720aca9a6ca4dd4dd8589 (patch)
treef37ab54819098e6bea8efbbab8c6a762ba45fe5e /net/unison-devel/Makefile
parent67d6dd12e0f99b448155b8b2971a76d36d5825a2 (diff)
downloadports-c9d7f519ed4d3020862720aca9a6ca4dd4dd8589.tar.gz
ports-c9d7f519ed4d3020862720aca9a6ca4dd4dd8589.zip
Notes
Diffstat (limited to 'net/unison-devel/Makefile')
-rw-r--r--net/unison-devel/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 92a300014e3d..fecfe3fe929e 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unison
PORTVERSION= 2.45.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
PKGNAMESUFFIX= -devel
@@ -26,8 +26,8 @@ WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
CONFLICTS= unison-[0-9]* unison-nox11-[0-9]*
-OPTIONS_DEFINE= DOCS GTK2
-OPTIONS_DEFAULT= DOCS GTK2
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT= DOCS X11
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= unison all
@@ -40,7 +40,7 @@ EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
.endif
-.if ${PORT_OPTIONS:MGTK2}
+.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
@@ -57,7 +57,7 @@ BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
PATCH_DEPENDS+= ${BUILD_DEPENDS}
.endif
-.if ${PORT_OPTIONS:MGTK2}
+.if ${PORT_OPTIONS:MX11}
post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
@@ -68,7 +68,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
post-install:
-.if ${PORT_OPTIONS:MGTK2}
+.if ${PORT_OPTIONS:MX11}
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -76,7 +76,7 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
.endif
-.if ${PORT_OPTIONS:MGTK2}
+.if ${PORT_OPTIONS:MX11}
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
@${MKDIR} ${DESKTOPDIR}
@${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${DESKTOPDIR}