aboutsummaryrefslogtreecommitdiff
path: root/net/uriparser
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-04-04 09:19:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-04-04 09:19:24 +0000
commit8e4c41baa17dcccfd6fc653073be84b00b6e87e7 (patch)
tree2d0ca63fb627783eb4bf6bf5c636191a4cd3327e /net/uriparser
parent83e659341f6c5e032f038ec19cc0023eccb4359a (diff)
downloadports-8e4c41baa17dcccfd6fc653073be84b00b6e87e7.tar.gz
ports-8e4c41baa17dcccfd6fc653073be84b00b6e87e7.zip
Notes
Diffstat (limited to 'net/uriparser')
-rw-r--r--net/uriparser/Makefile21
-rw-r--r--net/uriparser/distinfo3
-rw-r--r--net/uriparser/pkg-descr3
-rw-r--r--net/uriparser/pkg-plist10
4 files changed, 37 insertions, 0 deletions
diff --git a/net/uriparser/Makefile b/net/uriparser/Makefile
new file mode 100644
index 000000000000..31ee8fa7061e
--- /dev/null
+++ b/net/uriparser/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: uriparser
+# Date Created: 31 Mar 2007
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uriparser
+PORTVERSION= 0.3.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= uriparser
+
+MAINTAINER= ed@fxq.nl
+COMMENT= URI parsing library
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+CFLAGS+= -fPIC
+
+.include <bsd.port.mk>
diff --git a/net/uriparser/distinfo b/net/uriparser/distinfo
new file mode 100644
index 000000000000..a97226c25791
--- /dev/null
+++ b/net/uriparser/distinfo
@@ -0,0 +1,3 @@
+MD5 (uriparser-0.3.3.tar.bz2) = 8165a88502c1e4d71b7fc43fc802a732
+SHA256 (uriparser-0.3.3.tar.bz2) = 09b9ebe6b2631b4c9788a995e5cd6605a69f0552a7afc1c21d614b0ef168ae22
+SIZE (uriparser-0.3.3.tar.bz2) = 161626
diff --git a/net/uriparser/pkg-descr b/net/uriparser/pkg-descr
new file mode 100644
index 000000000000..097209b59b6a
--- /dev/null
+++ b/net/uriparser/pkg-descr
@@ -0,0 +1,3 @@
+uriparser is an RFC 3986 URI parsing library written in C++.
+
+WWW: http://uriparser.sourceforge.net/
diff --git a/net/uriparser/pkg-plist b/net/uriparser/pkg-plist
new file mode 100644
index 000000000000..e70c38fffba6
--- /dev/null
+++ b/net/uriparser/pkg-plist
@@ -0,0 +1,10 @@
+include/uriparser.h
+include/uriparser/Uri.h
+include/uriparser/UriBase.h
+include/uriparser/UriDefsAnsi.h
+include/uriparser/UriDefsConfig.h
+include/uriparser/UriDefsUnicode.h
+include/uriparser/UriIp4.h
+include/uriparser/UriIp4Base.h
+lib/liburiparser.a
+@dirrm include/uriparser