aboutsummaryrefslogtreecommitdiff
path: root/net/ushare
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-13 09:05:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-13 09:05:28 +0000
commitd4ddb9bcc699a959041fae11bc04438cd6b13391 (patch)
tree724dc237c7841261b624f912a31c4eb8e74713cf /net/ushare
parent28228e92d145cf7dc612ce71eaf621a38271b9c7 (diff)
downloadports-d4ddb9bcc699a959041fae11bc04438cd6b13391.tar.gz
ports-d4ddb9bcc699a959041fae11bc04438cd6b13391.zip
Notes
Diffstat (limited to 'net/ushare')
-rw-r--r--net/ushare/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/net/ushare/Makefile b/net/ushare/Makefile
index affafd215159..35e5f8fd63a0 100644
--- a/net/ushare/Makefile
+++ b/net/ushare/Makefile
@@ -7,13 +7,14 @@
PORTNAME= ushare
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ushare.geexbox.org/releases/
MAINTAINER= votdev@gmx.de
COMMENT= A lightweight UPnP (TM) A/V Media Server
-LIB_DEPENDS= upnp.2:${PORTSDIR}/devel/upnp
+LIB_DEPENDS= upnp.3:${PORTSDIR}/devel/upnp
BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample etc/rc.d/${PORTNAME}
@@ -21,8 +22,17 @@ MAN1= ${PORTNAME}.1
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}/lib --with-libintl-prefix=${LOCALBASE}/lib --mandir=${LOCALBASE}/man
USE_GNOME= pkgconfig
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}/lib \
+ --with-libintl-prefix=${LOCALBASE}/lib \
+ --mandir=${MANPREFIX}/man \
+ --with-libupnp-prefix=${LOCALBASE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+CFLAGS+= -lpthread
+.endif
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
@@ -30,4 +40,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/${PORTNAME} ${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/src/${PORTNAME}.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>