aboutsummaryrefslogtreecommitdiff
path: root/net/v6eval
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-01-31 02:32:19 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-01-31 02:32:19 +0000
commitad2d57dc8e8165975f29e9fad3432603d6634e5e (patch)
tree07afdc2ace6368d61c2deca852f8d024d5d57ba4 /net/v6eval
parentea1778d269477bbeaefe746a6f07f6567cf38933 (diff)
downloadports-ad2d57dc8e8165975f29e9fad3432603d6634e5e.tar.gz
ports-ad2d57dc8e8165975f29e9fad3432603d6634e5e.zip
Notes
Diffstat (limited to 'net/v6eval')
-rw-r--r--net/v6eval/Makefile9
-rw-r--r--net/v6eval/files/patch-Bpfilter.h11
-rw-r--r--net/v6eval/files/patch-McIKE.h11
-rw-r--r--net/v6eval/files/patch-MvFunction.cc10
-rw-r--r--net/v6eval/files/patch-RAFControl.h11
-rw-r--r--net/v6eval/files/patch-hmac.c11
-rw-r--r--net/v6eval/files/patch-sigcomp.c11
-rw-r--r--net/v6eval/files/patch-x509dec.c18
-rw-r--r--net/v6eval/pkg-plist4
9 files changed, 88 insertions, 8 deletions
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 2268e1bca436..014480b06a6c 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -7,6 +7,7 @@
PORTNAME= v6eval
PORTVERSION= 3.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tahi.org/release/v6eval/
@@ -19,13 +20,13 @@ RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect \
USE_PERL5= yes
USE_OPENSSL= yes
+MAN1PREFIX= ${PREFIX}/v6eval
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= pktctl.1.gz pktsend.1.gz
+MAN3= V6evalRemote.3 V6evalTool.3
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700019
-BROKEN= does not compile with OpenSSL 0.9.8b
-.endif
-
post-install:
@${SED} -e 's#@LOCALBASE@#${LOCALBASE}#' ${PKGMESSAGE}
diff --git a/net/v6eval/files/patch-Bpfilter.h b/net/v6eval/files/patch-Bpfilter.h
new file mode 100644
index 000000000000..4f56ee46dbf5
--- /dev/null
+++ b/net/v6eval/files/patch-Bpfilter.h
@@ -0,0 +1,11 @@
+--- lib/pkt/Bpfilter.h 2001-10-05 20:41:19.000000000 +0900
++++ lib/pkt/Bpfilter.h 2008-01-01 04:50:29.000000000 +0900
+@@ -62,7 +62,7 @@ public:
+ int statistics(uint32_t&,uint32_t&) const;
+ int receive(caddr_t) const;
+ int send(caddr_t,uint32_t) const;
+- uint32_t Bpfilter::getDLT() const;
++ uint32_t getDLT() const;
+ };
+ inline int Bpfilter::fileDesc() const {return fd_;}
+ inline uint32_t Bpfilter::bufferSize() const {return bufsize_;}
diff --git a/net/v6eval/files/patch-McIKE.h b/net/v6eval/files/patch-McIKE.h
new file mode 100644
index 000000000000..7cbe4a97943f
--- /dev/null
+++ b/net/v6eval/files/patch-McIKE.h
@@ -0,0 +1,11 @@
+--- lib/Pz/McIKE.h 2005-05-09 18:35:23.000000000 +0900
++++ lib/Pz/McIKE.h 2008-01-01 04:36:34.000000000 +0900
+@@ -397,7 +397,7 @@ class WmISAKMP_Padding: public WmObject
+
+ class PaISAKMP: public PaESP {
+ public:
+- PaISAKMP::PaISAKMP(const MObject *m, CSTR st, int l):
++ PaISAKMP(const MObject *m, CSTR st, int l):
+ PaESP(m, st, l) {};
+ virtual ~PaISAKMP() {}
+
diff --git a/net/v6eval/files/patch-MvFunction.cc b/net/v6eval/files/patch-MvFunction.cc
new file mode 100644
index 000000000000..f9924132c1b0
--- /dev/null
+++ b/net/v6eval/files/patch-MvFunction.cc
@@ -0,0 +1,10 @@
+--- lib/Pz/MvFunction.cc 2005-05-09 18:35:24.000000000 +0900
++++ lib/Pz/MvFunction.cc 2008-01-01 04:41:51.000000000 +0900
+@@ -71,6 +71,7 @@ extern "C" {
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <openssl/hmac.h>
++#include <openssl/md5.h>
+ #include <openssl/sha.h>
+ }
+
diff --git a/net/v6eval/files/patch-RAFControl.h b/net/v6eval/files/patch-RAFControl.h
new file mode 100644
index 000000000000..30cf23b14f4b
--- /dev/null
+++ b/net/v6eval/files/patch-RAFControl.h
@@ -0,0 +1,11 @@
+--- lib/pkt/RAFControl.h 2001-10-05 20:41:20.000000000 +0900
++++ lib/pkt/RAFControl.h 2008-01-01 04:49:37.000000000 +0900
+@@ -69,7 +69,7 @@ virtual const PaObject* pop_SA(eAlgorith
+ CSTR reverseEvaluate(const McObject&,PvOctets&,bool&);
+ bool evaluateWith(RObject*,WObject*) const;
+ WObject* evaluateAlgorithm(RObject*) const;
+- WObject* RAFControl::evaluate(RObject*);
++ WObject* evaluate(RObject*);
+ virtual void reset();
+ void applyFrame(const WObject* w) const;
+ const WAlgorithm* appliedAlgorithm() const;
diff --git a/net/v6eval/files/patch-hmac.c b/net/v6eval/files/patch-hmac.c
new file mode 100644
index 000000000000..54438e569464
--- /dev/null
+++ b/net/v6eval/files/patch-hmac.c
@@ -0,0 +1,11 @@
+--- lib/Pz/crypto/hmac/hmac.c 2002-05-27 18:56:19.000000000 +0900
++++ lib/Pz/crypto/hmac/hmac.c 2008-01-01 04:48:38.000000000 +0900
+@@ -60,7 +60,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <openssl/hmac.h>
++#include "hmac.h"
+
+ void HMAC_Init(HMAC_CTX *ctx, const void *key, int len,
+ const EVP_MD *md)
diff --git a/net/v6eval/files/patch-sigcomp.c b/net/v6eval/files/patch-sigcomp.c
new file mode 100644
index 000000000000..b14a8ea4a0be
--- /dev/null
+++ b/net/v6eval/files/patch-sigcomp.c
@@ -0,0 +1,11 @@
+--- bin/sigcomp/sigcomp.c 2005-05-27 20:40:19.000000000 +0900
++++ bin/sigcomp/sigcomp.c 2008-01-01 06:03:23.000000000 +0900
+@@ -53,7 +53,7 @@
+
+ #include <openssl/err.h>
+ #include <openssl/evp.h>
+-
++#include <openssl/rsa.h>
+
+
+ #ifdef DEBUG
diff --git a/net/v6eval/files/patch-x509dec.c b/net/v6eval/files/patch-x509dec.c
new file mode 100644
index 000000000000..fd6a9afa91cf
--- /dev/null
+++ b/net/v6eval/files/patch-x509dec.c
@@ -0,0 +1,18 @@
+--- bin/x509dec/x509dec.c 2005-05-30 19:17:31.000000000 +0900
++++ bin/x509dec/x509dec.c 2008-01-01 06:02:24.000000000 +0900
+@@ -244,13 +244,13 @@ x509dec_on_evp(const X509 *const x509)
+
+ TAILQ_INIT(&head);
+
+- if(!((unsigned char *)pubkey =
++ if(!(pubkey =
+ X509dec_get_pubkey(x509, &pubkeylen))) {
+
+ return(x509dec_on_evp_return(false, pubkey, subject_name));
+ }
+
+- if(!((unsigned char *)subject_name =
++ if(!(subject_name =
+ X509dec_get_subject_name(x509, (int *)&subject_namelen))) {
+
+ return(x509dec_on_evp_return(false, pubkey, subject_name));
diff --git a/net/v6eval/pkg-plist b/net/v6eval/pkg-plist
index cd416d5e6a7a..93d5c5eb4908 100644
--- a/net/v6eval/pkg-plist
+++ b/net/v6eval/pkg-plist
@@ -124,8 +124,6 @@ v6eval/include/std.def
v6eval/include/stdaddr.def
v6eval/include/stdconst.def
v6eval/include/stdpacket.def
-v6eval/man/man1/pktctl.1.gz
-v6eval/man/man1/pktsend.1.gz
@dirrm v6eval/bin/manual
@dirrm v6eval/bin/unknown
@dirrm v6eval/bin
@@ -135,8 +133,6 @@ v6eval/man/man1/pktsend.1.gz
@dirrm v6eval/man
@dirrmtry v6eval/etc
@dirrm v6eval
-lib/perl5/%%PERL_VERSION%%/man/man3/V6evalRemote.3
-lib/perl5/%%PERL_VERSION%%/man/man3/V6evalTool.3
%%SITE_PERL%%/V6evalCommon.pm
%%SITE_PERL%%/V6evalRemote.pm
%%SITE_PERL%%/V6evalTool.pm