aboutsummaryrefslogtreecommitdiff
path: root/net/vblade
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-09-14 13:33:53 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-09-14 13:33:53 +0000
commitda8f955a78311a3e1ccd014d576d842f7d0a729b (patch)
tree44c4810c388f696d2c9f73403295e79be3473bde /net/vblade
parentd35ce612b151dc1c7689bd42b55904af2803cf27 (diff)
downloadports-da8f955a78311a3e1ccd014d576d842f7d0a729b.tar.gz
ports-da8f955a78311a3e1ccd014d576d842f7d0a729b.zip
Notes
Diffstat (limited to 'net/vblade')
-rw-r--r--net/vblade/Makefile28
-rw-r--r--net/vblade/distinfo3
-rw-r--r--net/vblade/files/patch-makefile25
-rw-r--r--net/vblade/pkg-descr11
4 files changed, 67 insertions, 0 deletions
diff --git a/net/vblade/Makefile b/net/vblade/Makefile
new file mode 100644
index 000000000000..a4f4fb181a3d
--- /dev/null
+++ b/net/vblade/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: Virtual EtherDrive(R) blade AoE target
+# Date created: 14 Sep 2010
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vblade
+PORTVERSION= 20
+CATEGORIES= net
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= aoetools/${PORTNAME}/${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= Virtual EtherDrive(R) blade AoE target
+
+MAKE_ARGS= PLATFORM=freebsd\
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}"\
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}"\
+ INSTALL_MAN="${INSTALL_MAN}"
+MAKEFILE= makefile
+ALL_TARGET=
+
+PLIST_FILES= sbin/vblade sbin/vbladed
+MAN8= vblade.8
+
+.include <bsd.port.mk>
diff --git a/net/vblade/distinfo b/net/vblade/distinfo
new file mode 100644
index 000000000000..9a0e5829a590
--- /dev/null
+++ b/net/vblade/distinfo
@@ -0,0 +1,3 @@
+MD5 (vblade-20.tgz) = 3c80e4a6bc7d66ae0c235b88cb44bd59
+SHA256 (vblade-20.tgz) = c8fe2fc4f2fba8e07e5cfdf17335982584eef2cd5c78bf8b1db93f2b56e7121d
+SIZE (vblade-20.tgz) = 26689
diff --git a/net/vblade/files/patch-makefile b/net/vblade/files/patch-makefile
new file mode 100644
index 000000000000..69a312165865
--- /dev/null
+++ b/net/vblade/files/patch-makefile
@@ -0,0 +1,25 @@
+--- makefile.orig 2008-10-09 04:07:40.000000000 +0700
++++ makefile 2010-09-13 20:48:07.000000000 +0700
+@@ -3,10 +3,9 @@
+ # see README for others
+ PLATFORM=linux
+
+-prefix = /usr
++prefix = ${PREFIX}
+ sbindir = ${prefix}/sbin
+-sharedir = ${prefix}/share
+-mandir = ${sharedir}/man
++mandir = ${prefix}/man
+
+ O=aoe.o bpf.o ${PLATFORM}.o ata.o
+ CFLAGS += -Wall -g -O2
+@@ -38,6 +37,6 @@
+ rm -f $O vblade
+
+ install : vblade vbladed
+- install vblade ${sbindir}/
+- install vbladed ${sbindir}/
+- install vblade.8 ${mandir}/man8/
++ ${INSTALL_PROGRAM} vblade ${sbindir}/
++ ${INSTALL_SCRIPT} vbladed ${sbindir}/
++ ${INSTALL_MAN} vblade.8 ${mandir}/man8/
diff --git a/net/vblade/pkg-descr b/net/vblade/pkg-descr
new file mode 100644
index 000000000000..f0abd7962e0f
--- /dev/null
+++ b/net/vblade/pkg-descr
@@ -0,0 +1,11 @@
+The vblade is the virtual EtherDrive (R) blade, a program that makes a
+seekable file available over an ethernet local area network (LAN) via
+the ATA over Ethernet (AoE) protocol.
+
+The seekable file is typically a block device like /dev/md0 but even
+regular files will work. Sparse files can be especially convenient.
+When vblade exports the block storage over AoE it becomes a storage
+target. Another host on the same LAN can access the storage if it has
+a compatible aoe kernel driver.
+
+WWW: http://aoetools.sourceforge.net/