aboutsummaryrefslogtreecommitdiff
path: root/net/vinagre
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /net/vinagre
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Notes
Diffstat (limited to 'net/vinagre')
-rw-r--r--net/vinagre/.#Makefile.1.1751
-rw-r--r--net/vinagre/Makefile8
-rw-r--r--net/vinagre/distinfo6
-rw-r--r--net/vinagre/pkg-plist59
4 files changed, 105 insertions, 19 deletions
diff --git a/net/vinagre/.#Makefile.1.17 b/net/vinagre/.#Makefile.1.17
new file mode 100644
index 000000000000..2435a45c069a
--- /dev/null
+++ b/net/vinagre/.#Makefile.1.17
@@ -0,0 +1,51 @@
+# New ports collection makefile for: vinagre
+# Date created: 16 December 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net/vinagre/Makefile,v 1.17 2008/10/20 22:58:02 kwm Exp $
+#
+
+PORTNAME= vinagre
+PORTVERSION= 2.24.1
+PORTREVISION= 1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= VNC client for the GNOME Desktop
+
+LIB_DEPENDS= gtk-vnc-1.0.0:${PORTSDIR}/net/gtk-vnc \
+ avahi-core.6:${PORTSDIR}/net/avahi-app \
+ avahi-ui.0:${PORTSDIR}/net/avahi-gtk \
+ gnome-keyring:${PORTSDIR}/security/gnome-keyring
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomeprefix intlhack gnomehack libglade2 gconf2 gnomedocutils \
+ gnomepanel
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --enable-avahi
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= vinagre.schemas
+
+MAN1= vinagre.1
+
+post-install:
+ @-update-desktop-database > /dev/null
+ @-update-mime-database ${PREFIX}/share/mime > /dev/null
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS COPYING ChangeLog MAINTAINERS NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index d410fec4efea..fe5e59d677cb 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/vinagre/Makefile,v 1.5 2008/03/10 15:15:00 ahze Exp $
+# $MCom: ports/net/vinagre/Makefile,v 1.20 2008/12/31 21:16:54 mezz Exp $
#
PORTNAME= vinagre
-PORTVERSION= 0.5.2
+PORTVERSION= 2.24.2
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -22,7 +23,8 @@ LIB_DEPENDS= gtk-vnc-1.0.0:${PORTSDIR}/net/gtk-vnc \
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libglade2 gconf2 gnomedocutils
+USE_GNOME= gnomeprefix intlhack gnomehack libglade2 gconf2 gnomedocutils \
+ gnomepanel
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
diff --git a/net/vinagre/distinfo b/net/vinagre/distinfo
index e8cb385c408c..d08ef1d64156 100644
--- a/net/vinagre/distinfo
+++ b/net/vinagre/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/vinagre-0.5.2.tar.bz2) = abf277899e28ec9beea9a2f7c331267d
-SHA256 (gnome2/vinagre-0.5.2.tar.bz2) = b45f084343ad892bc303e2d0dada186d588ae6f0ccc419340024a2533e5a775b
-SIZE (gnome2/vinagre-0.5.2.tar.bz2) = 1031512
+MD5 (gnome2/vinagre-2.24.2.tar.bz2) = 330a65e0277a2c8fe746e2091c3198ce
+SHA256 (gnome2/vinagre-2.24.2.tar.bz2) = 57b4be4c8bfeeb1493e96b728ec6a4ac29b3e01217b03ce9b194e1932f538959
+SIZE (gnome2/vinagre-2.24.2.tar.bz2) = 1450774
diff --git a/net/vinagre/pkg-plist b/net/vinagre/pkg-plist
index e914b2b6a817..1b13279b6f25 100644
--- a/net/vinagre/pkg-plist
+++ b/net/vinagre/pkg-plist
@@ -1,4 +1,6 @@
bin/vinagre
+libdata/bonobo/servers/GNOME_VinagreApplet.server
+libexec/vinagre-applet
share/applications/vinagre-file.desktop
share/applications/vinagre.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -10,6 +12,12 @@ share/applications/vinagre.desktop
share/gnome/help/vinagre/C/figures/vinagre-screenshot.png
share/gnome/help/vinagre/C/legal.xml
share/gnome/help/vinagre/C/vinagre.xml
+share/gnome/help/vinagre/ca/figures/vinagre-screenshot.png
+share/gnome/help/vinagre/ca/vinagre.xml
+share/gnome/help/vinagre/cs/figures/vinagre-screenshot.png
+share/gnome/help/vinagre/cs/vinagre.xml
+share/gnome/help/vinagre/de/figures/vinagre-screenshot.png
+share/gnome/help/vinagre/de/vinagre.xml
share/gnome/help/vinagre/es/figures/vinagre-screenshot.png
share/gnome/help/vinagre/es/vinagre.xml
share/gnome/help/vinagre/fr/figures/vinagre-screenshot.png
@@ -24,6 +32,8 @@ share/gnome/help/vinagre/sq/figures/vinagre-screenshot.png
share/gnome/help/vinagre/sq/vinagre.xml
share/gnome/help/vinagre/sv/figures/vinagre-screenshot.png
share/gnome/help/vinagre/sv/vinagre.xml
+share/gnome/help/vinagre/th/figures/vinagre-screenshot.png
+share/gnome/help/vinagre/th/vinagre.xml
share/icons/hicolor/16x16/apps/vinagre.png
share/icons/hicolor/16x16/mimetypes/application-x-remote-connection.png
share/icons/hicolor/16x16/mimetypes/application-x-vnc.png
@@ -58,12 +68,15 @@ share/locale/eu/LC_MESSAGES/vinagre.mo
share/locale/fi/LC_MESSAGES/vinagre.mo
share/locale/fr/LC_MESSAGES/vinagre.mo
share/locale/gl/LC_MESSAGES/vinagre.mo
+share/locale/gu/LC_MESSAGES/vinagre.mo
share/locale/he/LC_MESSAGES/vinagre.mo
share/locale/hi/LC_MESSAGES/vinagre.mo
share/locale/hu/LC_MESSAGES/vinagre.mo
share/locale/it/LC_MESSAGES/vinagre.mo
share/locale/ja/LC_MESSAGES/vinagre.mo
+share/locale/kn/LC_MESSAGES/vinagre.mo
share/locale/ko/LC_MESSAGES/vinagre.mo
+share/locale/ku/LC_MESSAGES/vinagre.mo
share/locale/lt/LC_MESSAGES/vinagre.mo
share/locale/mk/LC_MESSAGES/vinagre.mo
share/locale/ml/LC_MESSAGES/vinagre.mo
@@ -72,6 +85,7 @@ share/locale/nb/LC_MESSAGES/vinagre.mo
share/locale/nl/LC_MESSAGES/vinagre.mo
share/locale/nn/LC_MESSAGES/vinagre.mo
share/locale/oc/LC_MESSAGES/vinagre.mo
+share/locale/or/LC_MESSAGES/vinagre.mo
share/locale/pa/LC_MESSAGES/vinagre.mo
share/locale/pl/LC_MESSAGES/vinagre.mo
share/locale/pt/LC_MESSAGES/vinagre.mo
@@ -80,12 +94,14 @@ share/locale/ru/LC_MESSAGES/vinagre.mo
share/locale/si/LC_MESSAGES/vinagre.mo
share/locale/sl/LC_MESSAGES/vinagre.mo
share/locale/sq/LC_MESSAGES/vinagre.mo
+share/locale/sr/LC_MESSAGES/vinagre.mo
+share/locale/sr@latin/LC_MESSAGES/vinagre.mo
share/locale/sv/LC_MESSAGES/vinagre.mo
share/locale/ta/LC_MESSAGES/vinagre.mo
share/locale/th/LC_MESSAGES/vinagre.mo
share/locale/tr/LC_MESSAGES/vinagre.mo
-share/locale/uk/LC_MESSAGES/vinagre.mo
share/locale/vi/LC_MESSAGES/vinagre.mo
+share/locale/uk/LC_MESSAGES/vinagre.mo
share/locale/zh_CN/LC_MESSAGES/vinagre.mo
share/locale/zh_HK/LC_MESSAGES/vinagre.mo
share/locale/zh_TW/LC_MESSAGES/vinagre.mo
@@ -93,6 +109,9 @@ share/mime/application/x-remote-connection.xml
share/mime/application/x-vnc.xml
share/mime/packages/vinagre-mime.xml
share/omf/vinagre/vinagre-C.omf
+share/omf/vinagre/vinagre-ca.omf
+share/omf/vinagre/vinagre-cs.omf
+share/omf/vinagre/vinagre-de.omf
share/omf/vinagre/vinagre-es.omf
share/omf/vinagre/vinagre-fr.omf
share/omf/vinagre/vinagre-it.omf
@@ -100,22 +119,14 @@ share/omf/vinagre/vinagre-oc.omf
share/omf/vinagre/vinagre-pt.omf
share/omf/vinagre/vinagre-sq.omf
share/omf/vinagre/vinagre-sv.omf
+share/omf/vinagre/vinagre-th.omf
+%%DATADIR%%/GNOME_VinagreApplet.xml
%%DATADIR%%/vinagre-ui.xml
%%DATADIR%%/vinagre.glade
@dirrm %%DATADIR%%
@dirrm share/omf/vinagre
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
+@dirrm share/gnome/help/vinagre/th/figures
+@dirrm share/gnome/help/vinagre/th
@dirrm share/gnome/help/vinagre/sv/figures
@dirrm share/gnome/help/vinagre/sv
@dirrm share/gnome/help/vinagre/sq/figures
@@ -130,6 +141,12 @@ share/omf/vinagre/vinagre-sv.omf
@dirrm share/gnome/help/vinagre/fr
@dirrm share/gnome/help/vinagre/es/figures
@dirrm share/gnome/help/vinagre/es
+@dirrm share/gnome/help/vinagre/de/figures
+@dirrm share/gnome/help/vinagre/de
+@dirrm share/gnome/help/vinagre/cs/figures
+@dirrm share/gnome/help/vinagre/cs
+@dirrm share/gnome/help/vinagre/ca/figures
+@dirrm share/gnome/help/vinagre/ca
@dirrm share/gnome/help/vinagre/C/figures
@dirrm share/gnome/help/vinagre/C
@dirrm share/gnome/help/vinagre
@@ -139,3 +156,19 @@ share/omf/vinagre/vinagre-sv.omf
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin