aboutsummaryrefslogtreecommitdiff
path: root/net/vino/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /net/vino/Makefile
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'net/vino/Makefile')
-rw-r--r--net/vino/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 12e0f5cc2f99..1ca45177c993 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -3,12 +3,11 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $MCom: ports/net/vino/Makefile,v 1.37 2007/03/12 13:41:32 ahze Exp $
+# $MCom: ports/net/vino/Makefile,v 1.48 2007/10/15 17:13:51 mezz Exp $
#
PORTNAME= vino
-PORTVERSION= 2.18.1
-PORTREVISION= 2
+PORTVERSION= 2.20.1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -27,9 +26,16 @@ GNOME_DESKTOP_VERSION=2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --enable-session-support
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= vino-server.schemas
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+CONFIGURE_ARGS+=--enable-libnotify=yes
+.else
+CONFIGURE_ARGS+=--enable-libnotify=no
+.endif
+
.include <bsd.port.mk>