aboutsummaryrefslogtreecommitdiff
path: root/net/vino
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-16 22:42:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-16 22:42:01 +0000
commitf75374592d96d50c228b412b144faf7b821b79c2 (patch)
tree8ef31f1609ad9bc8cf2bad65cf654f20093169e1 /net/vino
parent7eca0e4e9d1f931b3c8f4f8c760acddd58f0edcc (diff)
downloadports-f75374592d96d50c228b412b144faf7b821b79c2.tar.gz
ports-f75374592d96d50c228b412b144faf7b821b79c2.zip
Notes
Diffstat (limited to 'net/vino')
-rw-r--r--net/vino/Makefile27
-rw-r--r--net/vino/distinfo2
-rw-r--r--net/vino/files/patch-server_libvncserver_rfb_rfbproto.h12
-rw-r--r--net/vino/files/patch-server_vino-fb.c10
-rw-r--r--net/vino/pkg-descr4
-rw-r--r--net/vino/pkg-plist22
6 files changed, 77 insertions, 0 deletions
diff --git a/net/vino/Makefile b/net/vino/Makefile
new file mode 100644
index 000000000000..325fce3d66f0
--- /dev/null
+++ b/net/vino/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: vino
+# Date created: 16 July 2004
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vino
+PORTVERSION= 2.7.3.1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.7
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME 2 frontend for vncviewer
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix intlhack gnomehack gnomepanel
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/net/vino/distinfo b/net/vino/distinfo
new file mode 100644
index 000000000000..0915d22156f7
--- /dev/null
+++ b/net/vino/distinfo
@@ -0,0 +1,2 @@
+MD5 (vino-2.7.3.1.tar.bz2) = f3b06d2fe9f116f1b7badaa355ab33c2
+SIZE (vino-2.7.3.1.tar.bz2) = 561077
diff --git a/net/vino/files/patch-server_libvncserver_rfb_rfbproto.h b/net/vino/files/patch-server_libvncserver_rfb_rfbproto.h
new file mode 100644
index 000000000000..04d7fa7b588f
--- /dev/null
+++ b/net/vino/files/patch-server_libvncserver_rfb_rfbproto.h
@@ -0,0 +1,12 @@
+--- server/libvncserver/rfb/rfbproto.h.orig Fri Jul 16 18:16:16 2004
++++ server/libvncserver/rfb/rfbproto.h Fri Jul 16 18:16:39 2004
+@@ -60,7 +60,9 @@
+ #include <rfb/rfbint.h>
+ #else
+ #include <config.h>
++#ifdef HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #endif
+ #endif
+ #include <rfb/keysym.h>
diff --git a/net/vino/files/patch-server_vino-fb.c b/net/vino/files/patch-server_vino-fb.c
new file mode 100644
index 000000000000..56dbb89dcd07
--- /dev/null
+++ b/net/vino/files/patch-server_vino-fb.c
@@ -0,0 +1,10 @@
+--- server/vino-fb.c.orig Mon Jul 12 06:22:08 2004
++++ server/vino-fb.c Wed Jul 14 22:15:44 2004
+@@ -37,6 +37,7 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+ #include <gdk/gdkx.h>
+ #include <X11/Xlib.h>
diff --git a/net/vino/pkg-descr b/net/vino/pkg-descr
new file mode 100644
index 000000000000..f56a277004ba
--- /dev/null
+++ b/net/vino/pkg-descr
@@ -0,0 +1,4 @@
+Vino is a VNC server for GNOME - it allows someone to remotely connect
+to your desktop session using the RFB protocol.
+
+WWW: http://www.gnome.org
diff --git a/net/vino/pkg-plist b/net/vino/pkg-plist
new file mode 100644
index 000000000000..6678ff414f30
--- /dev/null
+++ b/net/vino/pkg-plist
@@ -0,0 +1,22 @@
+bin/vino-preferences
+bin/vino-session
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/vino-server.schemas > /dev/null || /usr/bin/true
+etc/gconf/schemas/vino-server.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/vino-server.schemas > /dev/null || /usr/bin/true
+libdata/bonobo/servers/GNOME_RemoteDesktop.server
+libexec/vino-server
+share/gnome/control-center-2.0/capplets/vino-preferences.desktop
+share/gnome/pixmaps/gnome-remote-desktop.png
+share/gnome/vino/vino-client.html
+share/gnome/vino/vino-client.jar
+share/gnome/vino/vino-preferences.glade
+share/gnome/vino/vino-prompt.glade
+share/locale/bg/LC_MESSAGES/vino.mo
+share/locale/cs/LC_MESSAGES/vino.mo
+share/locale/en_CA/LC_MESSAGES/vino.mo
+share/locale/en_GB/LC_MESSAGES/vino.mo
+share/locale/nl/LC_MESSAGES/vino.mo
+share/locale/pt/LC_MESSAGES/vino.mo
+share/locale/pt_BR/LC_MESSAGES/vino.mo
+share/locale/sv/LC_MESSAGES/vino.mo
+@dirrm share/gnome/vino