aboutsummaryrefslogtreecommitdiff
path: root/net/vls/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 05:02:19 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 05:02:19 +0000
commit8355761130d0c6c99616e8856de76a8621fd8b62 (patch)
treeb759e085753779fef1f93e9bd85089cd6087c510 /net/vls/Makefile
parenteb5d10f4aa2fc802ccc19b5c2b36a589b70ba16e (diff)
downloadports-8355761130d0c6c99616e8856de76a8621fd8b62.tar.gz
ports-8355761130d0c6c99616e8856de76a8621fd8b62.zip
Notes
Diffstat (limited to 'net/vls/Makefile')
-rw-r--r--net/vls/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/vls/Makefile b/net/vls/Makefile
new file mode 100644
index 000000000000..9a290e7cb660
--- /dev/null
+++ b/net/vls/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: vls
+# Date created: 3rd August 2001
+# Whom: Gleb Smirnoff <glebius@cell.sick.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vls
+PORTVERSION= 0.5.0
+CATEGORIES= net
+MASTER_SITES= http://www.videolan.org/pub/videolan/vls/${PORTVERSION}/
+
+MAINTAINER= glebius@cell.sick.ru
+COMMENT= An X11 video streaming client/server solution
+
+LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
+ dvbpsi.1:${PORTSDIR}/multimedia/libdvbpsi \
+ dvdread.3:${PORTSDIR}/multimedia/libdvdread
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-dvdcss=${LOCALBASE} \
+ --with-dvbpsi=${LOCALBASE} \
+ --with-dvdread=${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>