aboutsummaryrefslogtreecommitdiff
path: root/net/vnc/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-13 10:04:53 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-13 10:04:53 +0000
commite0873e1d9b5cb8fae03cb3219ca474e0da4fd594 (patch)
treecbd397d9abf689c73dcc9c2b43f534c76c61bd3b /net/vnc/Makefile
parente8ad5c106ae7d602997d3a20a42fc7a0507a7328 (diff)
downloadports-e0873e1d9b5cb8fae03cb3219ca474e0da4fd594.tar.gz
ports-e0873e1d9b5cb8fae03cb3219ca474e0da4fd594.zip
Notes
Diffstat (limited to 'net/vnc/Makefile')
-rw-r--r--net/vnc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index 5625ccd2ab28..93898bff8cf4 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -38,6 +38,12 @@ ${X11BASE}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/XFree8
USE_PERL5_RUN= yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-build:
.if !defined(WITHOUT_SERVER)
@${ECHO_MSG} "NOTE:"
@@ -96,4 +102,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/vncpasswd/vncpasswd.man ${PREFIX}/man/man1/vncpasswd.1
${INSTALL_MAN} ${WRKSRC}/vncconnect/vncconnect.man ${PREFIX}/man/man1/vncconnect.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>