aboutsummaryrefslogtreecommitdiff
path: root/net/vyqchat
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-17 22:40:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-17 22:40:23 +0000
commit05facefee14cd649e7cbd35ea8d3b89cfedbe668 (patch)
tree6e7c9b6a53cd6be2eb9ba31903811325b98f2b96 /net/vyqchat
parente13b8a362b0294cd784934ead5e4451a29fab95f (diff)
downloadports-05facefee14cd649e7cbd35ea8d3b89cfedbe668.tar.gz
ports-05facefee14cd649e7cbd35ea8d3b89cfedbe668.zip
Notes
Diffstat (limited to 'net/vyqchat')
-rw-r--r--net/vyqchat/Makefile41
-rw-r--r--net/vyqchat/distinfo2
-rw-r--r--net/vyqchat/files/patch-src-settings.cpp12
-rw-r--r--net/vyqchat/files/patch-src-uuid.cpp22
-rw-r--r--net/vyqchat/pkg-descr12
-rw-r--r--net/vyqchat/pkg-plist42
6 files changed, 131 insertions, 0 deletions
diff --git a/net/vyqchat/Makefile b/net/vyqchat/Makefile
new file mode 100644
index 000000000000..5a04afc65c71
--- /dev/null
+++ b/net/vyqchat/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: vyqchat
+# Date created: 25 August 2005
+# Whom: vic_semionov
+#
+# $FreeBSD$
+#
+
+PORTNAME= vyqchat
+PORTVERSION= 0.2.8
+CATEGORIES= net
+MASTER_SITES= http://linux.bydg.org/~yogin/
+
+MAINTAINER= semionov@mail.bg
+COMMENT= A Qt LAN chat, compatible with Vypress Chat
+
+USE_QT_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+QTCFGLIBS= ${PTHREAD_LIBS}
+
+CONFIGURE_ARGS= --with-Qt-dir=${QT_PREFIX}
+
+.if !defined(WITHOUT_ARTS)
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
+.else
+CONFIGURE_ARGS+=--without-arts
+.endif
+
+.if defined(WITH_LIBAO)
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+.else
+CONFIGURE_ARGS+=--without-libao
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/vyqchat/distinfo b/net/vyqchat/distinfo
new file mode 100644
index 000000000000..2899ba795ed8
--- /dev/null
+++ b/net/vyqchat/distinfo
@@ -0,0 +1,2 @@
+MD5 (vyqchat-0.2.8.tar.gz) = 67974bc5df1ed0d63785d04325444d4f
+SIZE (vyqchat-0.2.8.tar.gz) = 413505
diff --git a/net/vyqchat/files/patch-src-settings.cpp b/net/vyqchat/files/patch-src-settings.cpp
new file mode 100644
index 000000000000..7d17134e1258
--- /dev/null
+++ b/net/vyqchat/files/patch-src-settings.cpp
@@ -0,0 +1,12 @@
+--- src/settings.cpp Mon Jul 18 21:54:08 2005
++++ src/settings.cpp Sun Aug 7 15:59:58 2005
+@@ -14,8 +14,8 @@
+ #include "settings.h"
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+-#include <net/if.h>
+ #include <sys/socket.h>
++#include <net/if.h>
+ #include <sys/types.h>
+ #include <arpa/inet.h>
+ #include <stdlib.h>
diff --git a/net/vyqchat/files/patch-src-uuid.cpp b/net/vyqchat/files/patch-src-uuid.cpp
new file mode 100644
index 000000000000..10872796bcc0
--- /dev/null
+++ b/net/vyqchat/files/patch-src-uuid.cpp
@@ -0,0 +1,22 @@
+--- src/uuid.cpp.orig Mon Jul 18 20:54:08 2005
++++ src/uuid.cpp Sat Sep 17 23:03:48 2005
+@@ -12,7 +12,7 @@
+
+ #include "uuid.h"
+ #include <qstring.h>
+-#include <openssl/rand.h>
++#include <fcntl.h>
+
+ UUID::UUID(): QByteArray(UUID_LEN)/*{{{*/
+ {
+@@ -35,7 +35,9 @@
+
+ void UUID::generate()/*{{{*/
+ {
+- RAND_bytes((unsigned char *)data(), UUID_LEN);
++ int rfd = open("/dev/random", O_RDONLY);
++ read(rfd, (void *)data(), UUID_LEN);
++ close(rfd);
+ }/*}}}*/
+
+ void UUID::set(const unsigned char *data)/*{{{*/
diff --git a/net/vyqchat/pkg-descr b/net/vyqchat/pkg-descr
new file mode 100644
index 000000000000..d307ee1ba1ec
--- /dev/null
+++ b/net/vyqchat/pkg-descr
@@ -0,0 +1,12 @@
+VyQChat is a real-time, text-based, serverless chat program dedicated to LANs,
+that runs on Linux using Qt/X11 library. It is almost 100% compatible with
+Vypress Chat(TM) for Windows. It allows you to chat with friends on public or
+private channels, send and recieve messages etc. The GUI is meant to be
+user-friendly and lets you to do most things with mouse. There is also optional
+sound support. VyQChat has been written in C++ and requires Qt library, version
+3.x.
+
+WWW: http://linux.bydg.org/~yogin/
+
+- Victor Semionov
+semionov@mail.bg
diff --git a/net/vyqchat/pkg-plist b/net/vyqchat/pkg-plist
new file mode 100644
index 000000000000..988ac072131d
--- /dev/null
+++ b/net/vyqchat/pkg-plist
@@ -0,0 +1,42 @@
+bin/vyqchat
+share/vyqchat/default/channel_alert.png
+share/vyqchat/default/channel_normal.png
+share/vyqchat/default/channel.png
+share/vyqchat/default/comm.png
+share/vyqchat/default/enter.png
+share/vyqchat/default/info.png
+share/vyqchat/default/massmessage.png
+share/vyqchat/default/message.png
+share/vyqchat/default/priv_alert.png
+share/vyqchat/default/priv.png
+share/vyqchat/default/settings.png
+share/vyqchat/default/user_away.png
+share/vyqchat/default/user_dnd.png
+share/vyqchat/default/user_offline.png
+share/vyqchat/default/user.png
+share/vyqchat/default/themeinfo
+share/vyqchat/crystal/beep.png
+share/vyqchat/crystal/cancel.png
+share/vyqchat/crystal/channel_alert.png
+share/vyqchat/crystal/channel_normal.png
+share/vyqchat/crystal/channel.png
+share/vyqchat/crystal/comm.png
+share/vyqchat/crystal/enter.png
+share/vyqchat/crystal/info.png
+share/vyqchat/crystal/massmessage.png
+share/vyqchat/crystal/message.png
+share/vyqchat/crystal/priv_alert.png
+share/vyqchat/crystal/priv.png
+share/vyqchat/crystal/settings.png
+share/vyqchat/crystal/user_away.png
+share/vyqchat/crystal/user_dnd.png
+share/vyqchat/crystal/user_offline.png
+share/vyqchat/crystal/user.png
+share/vyqchat/crystal/themeinfo
+share/vyqchat/tr/vyqchat_pl.qm
+share/vyqchat/tr/vyqchat_ru.qm
+share/vyqchat/tr/vyqchat_tr.qm
+@dirrm share/vyqchat/default
+@dirrm share/vyqchat/crystal
+@dirrm share/vyqchat/tr
+@dirrm share/vyqchat