aboutsummaryrefslogtreecommitdiff
path: root/net/wackamole
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-04 07:57:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-04 07:57:52 +0000
commit12dc763d7d9cd338d1d20611ae7aa23419831e88 (patch)
treea2fd8e885c9b3cedfb33e9a81273a78b02f5c640 /net/wackamole
parent147ee0346ba0887efb9c2800256bb407027ccc25 (diff)
downloadports-12dc763d7d9cd338d1d20611ae7aa23419831e88.tar.gz
ports-12dc763d7d9cd338d1d20611ae7aa23419831e88.zip
Notes
Diffstat (limited to 'net/wackamole')
-rw-r--r--net/wackamole/Makefile25
-rw-r--r--net/wackamole/distinfo3
-rw-r--r--net/wackamole/pkg-descr15
-rw-r--r--net/wackamole/pkg-plist4
4 files changed, 47 insertions, 0 deletions
diff --git a/net/wackamole/Makefile b/net/wackamole/Makefile
new file mode 100644
index 000000000000..55873157a69e
--- /dev/null
+++ b/net/wackamole/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: wackamole
+# Date created: 2007-05-02
+# Whom: Marcin Cieslak <saper@system.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wackamole
+PORTVERSION= 2.1.3
+CATEGORIES= net
+MASTER_SITES= http://mirrors.omniti.com/wackamole/
+
+MAINTAINER= saper@system.pl
+COMMENT= Peer-to-peer high availability cluster
+
+LIB_DEPENDS= spread.1:${PORTSDIR}/net/spread
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV+= YACC=${YACC}
+
+MAN5= wackamole.conf.5
+MAN8= wackamole.8 wackatrl.8
+
+.include <bsd.port.mk>
diff --git a/net/wackamole/distinfo b/net/wackamole/distinfo
new file mode 100644
index 000000000000..69bc8959f9ec
--- /dev/null
+++ b/net/wackamole/distinfo
@@ -0,0 +1,3 @@
+MD5 (wackamole-2.1.3.tar.gz) = 25a2f9a664d534aa6e6d355144298cf8
+SHA256 (wackamole-2.1.3.tar.gz) = c4c80640bd26710121be687e16422783bacac8bfee168004ce9d165dce21ef87
+SIZE (wackamole-2.1.3.tar.gz) = 180948
diff --git a/net/wackamole/pkg-descr b/net/wackamole/pkg-descr
new file mode 100644
index 000000000000..ffd27dd41b80
--- /dev/null
+++ b/net/wackamole/pkg-descr
@@ -0,0 +1,15 @@
+Wackamole is an application that helps with making a cluster highly
+available.
+
+It manages a bunch of virtual IPs, that should be available
+to the outside world at all times. Wackamole ensures that a single
+machine within a cluster is listening on each virtual IP address
+that Wackamole manages. If it discovers that particular machines
+within the cluster are not alive, it will almost immediately ensure
+that other machines acquire these public IPs.
+At no time will more than one machine listen on any virtual IP.
+
+Wackamole also works toward achieving a balanced distribution of
+number IPs on the machine within the cluster it manages.
+
+WWW: http://www.backhand.org/wackamole/
diff --git a/net/wackamole/pkg-plist b/net/wackamole/pkg-plist
new file mode 100644
index 000000000000..c23f1f3ac77c
--- /dev/null
+++ b/net/wackamole/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+etc/wackamole.conf.sample
+sbin/wackamole
+sbin/wackatrl