aboutsummaryrefslogtreecommitdiff
path: root/net/whois/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-19 11:17:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-19 11:17:36 +0000
commitb53fd2df7b4d6c390b7f0247ed9fd619f2bd9287 (patch)
tree44d0683410d41b0b511da371490569c8fc37be28 /net/whois/Makefile
parent9f5dbeb28e8521f3bcdb55f60b9cffb0972971fc (diff)
downloadports-b53fd2df7b4d6c390b7f0247ed9fd619f2bd9287.tar.gz
ports-b53fd2df7b4d6c390b7f0247ed9fd619f2bd9287.zip
Notes
Diffstat (limited to 'net/whois/Makefile')
-rw-r--r--net/whois/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/net/whois/Makefile b/net/whois/Makefile
index e76088c173a6..dbacff7a0296 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= whois
-PORTVERSION= 4.6.13
+PORTVERSION= 4.6.14
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,20 +16,35 @@ COMMENT= Marco d'Itri whois client
MAN1= whois.1
-USE_GETTEXT= yes
USE_ICONV= yes
USE_PERL5_BUILD= yes
USE_REINPLACE= yes
-USE_GMAKE= yes
USE_GETOPT_LONG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ARGS= OPTS=""
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+LDFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+NO_PO= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|prefix\=/usr/local|prefix\=${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|/usr/share|${PREFIX}/share|g" ${WRKSRC}/po/Makefile
+ @if [ -n "${NO_PO}" ]; \
+ then ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/have_nls-patch; \
+ fi
+
+post-install:
+ @if [ ! -n "${NO_PO}" ]; \
+ then cd ${WRKSRC}/po && ${MAKE} install; \
+ fi
.include <bsd.port.mk>