aboutsummaryrefslogtreecommitdiff
path: root/net/widentd
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-08-31 12:54:25 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-08-31 12:54:25 +0000
commit9a8c9c7082f9f6340d7c6819291df4a7b63ccfc8 (patch)
treef77cc7948ec146828b5ac0530588b3070bc94a77 /net/widentd
parent60bdac9350f1c2409ba9c323e8ff78c32c5f6841 (diff)
downloadports-9a8c9c7082f9f6340d7c6819291df4a7b63ccfc8.tar.gz
ports-9a8c9c7082f9f6340d7c6819291df4a7b63ccfc8.zip
Notes
Diffstat (limited to 'net/widentd')
-rw-r--r--net/widentd/Makefile2
-rw-r--r--net/widentd/files/widentd.sh.in38
2 files changed, 40 insertions, 0 deletions
diff --git a/net/widentd/Makefile b/net/widentd/Makefile
index 33d9894c536d..238f1e2678bf 100644
--- a/net/widentd/Makefile
+++ b/net/widentd/Makefile
@@ -8,6 +8,7 @@
PORTNAME= widentd
PORTVERSION= 1.03
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.webweaving.org/widentd/
EXTRACT_SUFX= .tgz
@@ -18,6 +19,7 @@ COMMENT= RFC1413 auth/identd daemon with fixed fake reply
MAN8= widentd.8
MANCOMPRESSED= yes
PLIST_FILES= sbin/widentd
+USE_RC_SUBR= widentd.sh
MAKE_ENV+= BINDIR="${PREFIX}/sbin" MANDIR="${PREFIX}/man/man"
diff --git a/net/widentd/files/widentd.sh.in b/net/widentd/files/widentd.sh.in
new file mode 100644
index 000000000000..f71b1ad72a90
--- /dev/null
+++ b/net/widentd/files/widentd.sh.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+# Start or stop widentd
+#
+# $FreeBSD$
+#
+# PROVIDE: widentd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: FreeBSD startup and shutdown
+#
+prefix=%%PREFIX%%
+
+# Define these widentd_* variables in one of these files:
+#
+# /etc/rc.conf
+# /etc/rc.conf.local
+#
+# e.g.
+# widentd_enable="YES"
+#
+# see the man page at widentd(8) for
+# some additional flags to set the IP address
+# beeing bound to, or how to set a differernt
+# fake user id beeing replied as.
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+widentd_enable=${widentd_enable-"NO"}
+
+. %%RC_SUBR%%
+
+name="widentd"
+rcvar=`set_rcvar`
+command="${prefix}/sbin/widentd"
+
+load_rc_config $name
+
+run_rc_command "$1"