aboutsummaryrefslogtreecommitdiff
path: root/net/widentd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-19 14:13:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-19 14:13:27 +0000
commit74ba11be5b90c07b1e42199570dc58383efe9b87 (patch)
tree5f19907c37ae95477ce0a4b0c262e62ffd95fcce /net/widentd
parenta8c164659f3ac85e1df96f7e077db8e148320cab (diff)
downloadports-74ba11be5b90c07b1e42199570dc58383efe9b87.tar.gz
ports-74ba11be5b90c07b1e42199570dc58383efe9b87.zip
Notes
Diffstat (limited to 'net/widentd')
-rw-r--r--net/widentd/Makefile2
-rw-r--r--net/widentd/files/patch-widentd.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/net/widentd/Makefile b/net/widentd/Makefile
index ebb7a25e89ad..731b88246497 100644
--- a/net/widentd/Makefile
+++ b/net/widentd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= widentd
PORTVERSION= 1.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://www.webweaving.org/widentd/
EXTRACT_SUFX= .tgz
diff --git a/net/widentd/files/patch-widentd.c b/net/widentd/files/patch-widentd.c
new file mode 100644
index 000000000000..04a39728b65f
--- /dev/null
+++ b/net/widentd/files/patch-widentd.c
@@ -0,0 +1,22 @@
+--- widentd.c.orig
++++ widentd.c
+@@ -41,9 +41,6 @@
+
+ #define SERVICE ("ident") /* 113 */
+
+-int verbose = 0;
+-const char *user = UID;
+-const char *os = OS;
+
+ static void
+ usage(void)
+@@ -64,6 +61,9 @@ main(int argc, char **argv)
+ fd_set *lst = malloc(FD_SETSIZE), *xst = malloc(FD_SETSIZE),
+ *wst = malloc(FD_SETSIZE);
+ struct addrinfo *ports, *p;
++ int verbose = 0;
++ const char *user = UID;
++ const char *os = OS;
+ const char * node = NULL, * service = SERVICE;
+ struct addrinfo hints;
+ int s = -1;