aboutsummaryrefslogtreecommitdiff
path: root/net/wired/pkg-install
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-04 22:03:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-04 22:03:13 +0000
commit3b45eafeafcea4e0b1120e167f953b5809d51c32 (patch)
treea4fff6ed39ece1bed1dea86018678455752984c8 /net/wired/pkg-install
parent9ea22cc9bf90283d27dfb6fcfc5853e6cd0b739c (diff)
Notes
Diffstat (limited to 'net/wired/pkg-install')
-rw-r--r--net/wired/pkg-install3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/wired/pkg-install b/net/wired/pkg-install
index 3667f4bf8fe8..35af862613ac 100644
--- a/net/wired/pkg-install
+++ b/net/wired/pkg-install
@@ -72,6 +72,9 @@ PRE-INSTALL)
POST-INSTALL)
openssl req -batch -new -x509 -nodes -out ${PKG_PREFIX}/wired/etc/certificate.pem.sample -keyout ${PKG_PREFIX}/wired/etc/certificate.pem.sample;
+
+ # We have to do this here instead of @exec in pkg-plist, because @exec clause
+ # is executed before POST-INSTALL, which creates the certificate.pem.sample.
if [ ! -f ${PKG_PREFIX}/wired/etc/certificate.pem ]; then
cp -p ${PKG_PREFIX}/wired/etc/certificate.pem.sample ${PKG_PREFIX}/wired/etc/certificate.pem;
fi