aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-05-22 05:23:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-05-22 05:23:54 +0000
commitdf12b2dc6113ebb132740c22f30c0f90247fa848 (patch)
tree81a86c40d9219b4a5f2d2b642f275a5f0ada6a62 /net/wireshark/Makefile
parent96018cc6826e36397589ba4670177e663ef0cd23 (diff)
downloadports-df12b2dc6113ebb132740c22f30c0f90247fa848.tar.gz
ports-df12b2dc6113ebb132740c22f30c0f90247fa848.zip
Notes
Diffstat (limited to 'net/wireshark/Makefile')
-rw-r--r--net/wireshark/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 596268fb11dc..d7c81999ae1f 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -70,7 +70,8 @@ OPTIONS= RTP "Enable support for playing back RTP streams" off \
PCRE "Enable regular expression matching support" on \
IPV6 "Enable IPv6 support" on \
GEOIP "Enable GeoIP lookups" on \
- LUA "Enable LUA scripting integration" off
+ LUA "Enable LUA scripting integration" off \
+ CARES "Asynchronous DNS resolution via c-ares" off
.endif
.include <bsd.port.pre.mk>
@@ -140,6 +141,13 @@ CONFIGURE_ARGS+= --with-adns=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-adns=no
.endif
+.if !defined(WITHOUT_CARES) && !defined(LITE)
+LIB_DEPENDS+= cares.2:${PORTSDIR}/dns/c-ares
+CONFIGURE_ARGS+= --with-c-ares=${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+= --with-c-ares=no
+.endif
+
.if !defined(WITHOUT_GEOIP) && !defined(LITE)
LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= --with-geoip=${LOCALBASE}/lib