aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-28 22:58:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-28 22:58:19 +0000
commit04316421dd6d2f88b231d2af079bfa5ccd84e3ac (patch)
tree6ae9b0614418c5eb59299e48c6f00aec6464591b /net/wireshark
parentc3a525858efec7d5e34b24a1dd6de21611d6d53a (diff)
downloadports-04316421dd6d2f88b231d2af079bfa5ccd84e3ac.tar.gz
ports-04316421dd6d2f88b231d2af079bfa5ccd84e3ac.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index ceff626e905f..4889033828b7 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -19,17 +19,21 @@ MASTER_SITE_SUBDIR= . old-versions
MAINTAINER= billf@FreeBSD.org
COMMENT= An X11/GTK network analyzer/capture tool
+USE_BZIP2= yes
+WANT_GNOME= yes
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_SNMP)
LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
.endif
-USE_BZIP2= yes
CONFIGURE_ARGS= --program-transform-name=""
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if !defined(WITHOUT_X11)
USE_X_PREFIX= yes
-.if defined(WITH_GTK2)
-LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20
+.if defined(WITH_GTK2) || (${HAVE_GNOME:Mgtk20}!="")
+USE_GNOME= gtk20
CONFIGURE_ARGS+= --enable-gtk2=yes
.else
USE_GNOME= gtk12
@@ -60,7 +64,7 @@ CONFIGURE_ARGS+= --enable-snmp=no --without-ucdsnmp --without-net-snmp
.if defined(WITH_ADNS) || (!defined(WITHOUT_ADNS) && exists(${LOCALBASE}/lib/adns.so))
LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
-CONFIGURE_ARGS+= --with-adns=${LOCALBASE}
+.include <bsd.port.post.mk>
.else
CONFIGURE_ARGS+= --without-adns
.endif
@@ -68,4 +72,4 @@ CONFIGURE_ARGS+= --without-adns
MAN1+= editcap.1 idl2eth.1 mergecap.1 tethereal.1 text2pcap.1
MAN4+= ethereal-filter.4
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>