aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-10-11 05:52:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-10-11 05:52:06 +0000
commita600d6dbd2c6a27c9c8564d07f210176f7cbc9c6 (patch)
tree5a5f2d91c29cc6974e21d374bb31fdfd5d4aed62 /net/wireshark
parent84208f2ca5438c4bbd2c55c71db28f24b4f208dd (diff)
downloadports-a600d6dbd2c6a27c9c8564d07f210176f7cbc9c6.tar.gz
ports-a600d6dbd2c6a27c9c8564d07f210176f7cbc9c6.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile17
-rw-r--r--net/wireshark/files/patch-Makefile.in10
-rw-r--r--net/wireshark/files/patch-epan_Makefile.in17
-rw-r--r--net/wireshark/pkg-plist3
4 files changed, 35 insertions, 12 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 726eb57333d4..02cb52d684ec 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -70,7 +70,8 @@ OPTIONS= RTP "Enable support for playing back RTP streams" off \
ADNS "Enable asynchronous DNS lookup support" on \
PCRE "Enable regular expression matching support" on \
IPV6 "Enable IPv6 support" on \
- GEOIP "Enable GeoIP lookups" on
+ GEOIP "Enable GeoIP lookups" on \
+ LUA " Enable LUA scripting integration" off
.endif
.include <bsd.port.pre.mk>
@@ -109,14 +110,14 @@ CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-pcre=no
.endif
-#.if defined(WITH_LUA) && !defined(LITE)
-#USE_LUA= 5.1
-#CONFIGURE_ARGS+=--with-lua=${LUA_PREFIX}
-#PLIST_SUB+= LUA=""
-#.else
+.if defined(WITH_LUA) && !defined(LITE)
+USE_LUA= 5.1
+CONFIGURE_ARGS+=--with-lua=${LUA_PREFIX}
+PLIST_SUB+= LUA=""
+.else
CONFIGURE_ARGS+=--without-lua
-#PLIST_SUB+= LUA="@comment "
-#.endif
+PLIST_SUB+= LUA="@comment "
+.endif
.if defined(WITH_RTP) && !defined(LITE)
LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio
diff --git a/net/wireshark/files/patch-Makefile.in b/net/wireshark/files/patch-Makefile.in
new file mode 100644
index 000000000000..38553c5e4dc5
--- /dev/null
+++ b/net/wireshark/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2009-10-11 01:36:04.000000000 -0400
++++ Makefile.in 2009-10-11 01:36:22.000000000 -0400
+@@ -570,6 +570,7 @@ wireshark_man = @wireshark_man@
+ wiresharkfilter_man = @wiresharkfilter_man@
+ ACLOCAL_AMFLAGS = `./aclocal-flags`
+ INCLUDES = @LUA_INCLUDES@
++LIBS = @LUA_LIBS@
+ @HAVE_WARNINGS_AS_ERRORS_TRUE@AM_CLEAN_CFLAGS = -Werror
+
+ #
diff --git a/net/wireshark/files/patch-epan_Makefile.in b/net/wireshark/files/patch-epan_Makefile.in
index 6b411a68bd85..c651a82049d5 100644
--- a/net/wireshark/files/patch-epan_Makefile.in
+++ b/net/wireshark/files/patch-epan_Makefile.in
@@ -1,6 +1,15 @@
---- epan/Makefile.in.orig 2009-06-16 00:04:18.000000000 -0400
-+++ epan/Makefile.in 2009-06-20 18:40:38.000000000 -0400
-@@ -770,7 +770,7 @@ MAINTAINERCLEANFILES = \
+--- epan/Makefile.in.orig 2009-09-14 21:51:20.000000000 -0400
++++ epan/Makefile.in 2009-10-11 01:37:24.000000000 -0400
+@@ -694,6 +694,8 @@ INCLUDES = -I$(srcdir)/.. -I$(srcdir)/$(
+ $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) \
+ $(LIBGEOIP_CFLAGS)
+
++LIBS = @LUA_LIBS@
++
+ @HAVE_WARNINGS_AS_ERRORS_TRUE@AM_NON_GENERATED_CFLAGS = -Werror
+
+ #Since code generated by lex may trigger gcc warnings, we are now generating two
+@@ -766,7 +768,7 @@ MAINTAINERCLEANFILES = \
# Add the object files for missing routines, if any.
#
libwireshark_la_LIBADD = \
@@ -9,7 +18,7 @@
libwireshark_asmopt.la crc/libcrc.la crypt/libairpdcap.la \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la $(wslua_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
-@@ -779,7 +779,7 @@ libwireshark_la_LIBADD = \
+@@ -775,7 +777,7 @@ libwireshark_la_LIBADD = \
${top_builddir}/wsutil/libwsutil.la -lm
libwireshark_la_DEPENDENCIES = \
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index 47b946a83483..b49a541a9043 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -59,7 +59,9 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/capinfos.html
%%DATADIR%%/cfilters
%%DATADIR%%/colorfilters
+%%LUA%%%%DATADIR%%/console.lua
%%DATADIR%%/dfilters
+%%LUA%%%%DATADIR%%/dtd_gen.lua
%%DATADIR%%/dumpcap.html
%%DATADIR%%/diameter/Ericsson.xml
%%DATADIR%%/diameter/TGPPGmb.xml
@@ -89,6 +91,7 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/dtds/xcap-caps.dtd
%%DATADIR%%/dtds/xcap-error.dtd
%%DATADIR%%/editcap.html
+%%LUA%%%%DATADIR%%/init.lua
%%DATADIR%%/services
%%DATADIR%%/smi_modules
%%DATADIR%%/tpncp/tpncp.dat