aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-12-20 00:14:56 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-12-20 00:14:56 +0000
commit6210b06f31afbd2343cedb9d95f1d40b981cc9a7 (patch)
tree57ad17f36e2b87cc236f0254a62cec74dd715433 /net/wireshark
parentaa635c3cda6ff98afbe305f9f65d2c18f544e745 (diff)
downloadports-6210b06f31afbd2343cedb9d95f1d40b981cc9a7.tar.gz
ports-6210b06f31afbd2343cedb9d95f1d40b981cc9a7.zip
Notes
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile21
-rw-r--r--net/wireshark/pkg-plist1
2 files changed, 17 insertions, 5 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index d9bb4ed3aacb..0a6b97b2d75a 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= wireshark
PORTVERSION= 1.6.4
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://wireshark.osmirror.nl/download/src/ \
@@ -38,6 +39,10 @@ DATADIR= ${PREFIX}/share/${DATADIR_NAME}
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -funit-at-a-time
+DESKTOP_ENTRIES= "Wireshark" "Network Protocol Analyzer" \
+ "${DATADIR}/hi48-app-wireshark.png" \
+ "wireshark" "System;Monitor;GTK;" true
+
WIRESHARK_LIBS=
.for x in capinfos editcap idl2wrs mergecap rawshark text2pcap dftest randpkt
@@ -146,13 +151,16 @@ CONFIGURE_ARGS+= --with-geoip=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-geoip=no
.endif
-.if exists(${LOCALBASE}/lib/libgnutls.so) || !defined(WITHOUT_GNUTLS)
+.if !defined(WITHOUT_GNUTLS)
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
- gcrypt.18:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+=--with-libgnutls-prefix=${LOCALBASE}
+ gcrypt.18:${PORTSDIR}/security/libgcrypt
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE} \
+ --with-gnutls=yes
+.else
+CONFIGURE_ARGS+=--with-gnutls=no
.endif
-.if exists(${LOCALBASE}/lib/libgcrypt.so) || !defined(WITHOUT_LIBGCRYPT)
+.if !defined(WITHOUT_LIBGCRYPT)
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
.endif
@@ -162,7 +170,10 @@ MAN4+= wireshark-filter.4
post-patch:
@${REINPLACE_CMD} -e 's|lua5\.1|lua${LUA_VER_STR}|g ; \
- s|-llua${LUA_VER_STR}|${LUA_LIBDIR}/liblua.a|g' \
+ s|-llua${LUA_VER_STR}|${LUA_LIBDIR}/liblua.a|g' \
${WRKSRC}/configure
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/image/hi48-app-wireshark.png ${DATADIR}
+
.include <bsd.port.post.mk>
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index d9c8f03680bd..c34276152811 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -105,6 +105,7 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/help/getting_started.txt
%%DATADIR%%/help/overview.txt
%%DATADIR%%/help/toc
+%%DATADIR%%/hi48-app-wireshark.png
%%DATADIR%%/idl2wrs.html
%%DATADIR%%/ipmap.html
%%DATADIR%%/manuf